Flattery & Unfold tool installation problems


#1

Hi there,

I have been trying to install both these two plugins Unfold tool, and Flattery:

I have followed the installation steps perfectly several times and it doesn’t load into my SU. I have tried two ways of install for each. One way was per the instructions, I have tried both copy and pasting the rb file into the 2015 SU plugin folder, then reopened SU but there were no icons, toolbars or anything in the menus in SU.

The second way I simply tried opening either rb file from within SU preferences/extensions however I cannot click on either of the rb files as they show in shaded grey colour (not openable).

The only thing that shows in SU is the flattery extension with a “tick” in the extensions window, however its not in any menus, toolbars or right click menu… nothing…

Im using SKUP 2015, on a mac book pro.

Could you let me know what could be wrong? I have seen many people in the last recent years 2012-2014 being able to install it no problem…

Cheers for any ideas…

Wolfgang


#2

Have you been copying plugins from older versions ?
This is not advisable - many were updated to suit Ruby2 used in the newer SketchUps…
Get the latest versions wherever possible.
Where did you get this version of ‘Flattery’ from ?
The older Flattery version [on its website] is incompatible with the newer SketchUps.
Under its copyright license I did update the script hosted at SketchUcation’s PluginStore, to make it compatible.
You should get the RBZ from there and install it using the SketchUp > Preferences > Extensions > Install… button…
Here’s a link:
http://sketchucation.com/pluginstore?pln=Flattery

I’m sure Jim Foltz will comment about his oldie ‘Unfold’ - which is available through his own web-site…


#3

Hi TIG,
I’m a student in design and we have used successfully the fantastic plugin Flattery in some simple projects. We also used it to educate many children in the rural areas of Bangkok, Thailand. We are using SU 8 on PC and it works well so far, but those pc are very old and they will be replaced by new ones in a few months. That means that we will upgrade to SU2015…

Unfortunately for me I updated my SU to SU2015 on a Mac. Since then, Flattery doesn’t work.
I could get a RBZ file (as_flatten.rbz) in my SU2015 plugin folder, but it gives me a Load Error message when opening SU.

If by any chance you can help, that would be fantastic. Your work helped us educate 100s of kids and students.
Also, please understand that I can’t pay to access your www.sketchucation.com
Flattery was a free plugin, we hope it can remain that way.

Thank you very much for your time.
Best regards


#4

Sketchucation is free, you only need to register.
The link Tig posted is to the latest version, it is free and it works with SU2015.

A .RBZ file is a zipped install file and should be installed using the Install extension button in Preferences.


#5

Ok… I don’t understand something here… I went to that website 4 or 5 times since yesterday and it is asking for a 15$ per month to register.
Am I looking at the wrong thing?


#6

Just register for the free version not the premium.


#7

Hi Box,

Thanks for helping!
I don’t see any free version.
Perhaps, they don’t let people living in Asia register on their website? lol


#8

Oh! I finally found a hidden link in tiny, down in the FAQ…


#9

Thank you for your wise insistence! I finally found the link to register free of charge.
One have to admit that the design of their register page is meant to make you believe you have to pay.
Thank you very much!