Flattery Plugin Crashes on SU Pro 2016 for Win10 or OSX

Is anyone else having issues with Flattery? The extension will intermittently Bugsplat SU Pro 2016. This is has been happening in our classroom on the lab Mac Pros as well. I have tried to isolate by trying the extension on a clean install on my Windows partition today. Unfortunately, I get the same results.

I will start with a simple Platonic Solid like a dodecahedron. I map all the vertices. The unfold begins pretty easy, but will crash somewhere between the 5 and 10th unfold procedure.

I cannot find any mention of this problem while searching the web. Can anyone provide any ideas on what to investigate?

I haven’t had any problems with flattery on Windows 10. Is it possible there’s some conflict with another extension? You might try running it with the Ruby Console open to see if there are any errors being shown while unfolding. Are you getting bug Splats? Are you sending them with any identifying info like name or e-mail address?

Did you get the latest Flattery version from SketchUcation’s PluginStore ?
http://sketchucation.com/pluginstore?pln=Flattery
It was adjusted to work with newer versions of SketchUp.
The original version from its website seems to be no longer supported and is out-of-date…

If you have the newest version and it’s still failing can you post any Ruby Console messages that appear when it fails…

1 Like

I haven’t been sending the messages. I have been lame. Let me start today.

Yep TIG! Sure did. It was a clean install/first time install on my Win10 partition this afternoon. I will start recording the Ruby console messages.

@DaveR will the BugSplat report numbers be enough? These 3 crashes were under MBP, 2.2 GHz Intel Core i7,16 GB 1600 MHz DDR3, OSX El Cap, Intel Iris Pro 1536 MB.

Crash Report #39518
Crash Report #39519
Crash Report #39520
Or my name Thomas Asmuth

p.s. @TIG I just installed a fresh copy of Flattery from Sketchucation

I’m not in a position to look up the crashes but maybe @Barry could if he pops in.

OK. I have just tried to reproduce the problem on my Desktop and I get the same problems. Mac Pro, @ x 2.4 GHz Quad-Core, 16 Gb 1066MHz, ATI Radeon HD 5870.

can you post a skp that’s crashing…

how ‘small’ is the smallest edge?

john

@john_drivenupthewall it is a platonic solid: all edges are the same. The model I was working with this afternoon had 1 foot edges.

@TIG I don’t see any messages in the Ruby Console in these procedures. Should I get some feedback while working?

I just tried a to delete all Sketchup program files. Using a utility that seeks out all connected files for SU16 I get this list. Is it possible there is an old cache or pref folder/file not deleting and causing the conflict/crash?

And now I have tested it on SU Pro 2015. It works all day long, beautifully.

I am more suspicious that there is a some cache somewhere that is not being cleared when I uninstall/delete the old program files. I suspect that this is causing the crash/conflict. I base part of this observation on the fact that I deleted all related Application support and Pref files, restarted my MBP, and reinstalled SU15. When I started it still had files I created/worked on over a month ago in the "recent files’ menu.

I would really rather teach with 2016. Any thoughts? I have to purchase software licenses next week.

When we test SketchUp, our cleanup scripts also remove:
~/Library/Caches/com.sketchup.SketchUp.2016/
~/Library/Application Support/SketchUp 2016/
~/Library/Saved\ Application\ State/com.sketchup.SketchUp.2016
~/Library/Preferences/com.sketchup.SketchUp.2016*

And then remember that new MacOS’s use Core Foundation Preferences daemon, so they’re cached, and you have to either logout & log back in or do (Terminal.app) killall cfprefsd

And confirm there’s nothing in /Library/Application Support/ that’s SketchUp related.

@Barry Thanks for all those steps. I just followed all of the steps and I am still having issues.

My procedure:
I looked in each location and double checked that all files were eliminated, emptied Trash, ran the Terminal script, and logged off and back in.
I reinstalled SU2016, downloaded Flattery fresh from @TIG 's link.
Installed Flattery using the Preferences dialog box.
Drew a simple solid 6 or 7 faces with edges over one foot.
I mapped the edges using Flattery, used flatten tool from Flattery to successfully flatten one object.
Opened a new work space.
Drew a simple solid 6 or 7 faces with edges over one foot. Mapped.
When used the Flatten tool from Flattery, SU16 crashed and shutdown.
Filed a BUGSPLAT

1 Like

Same same. It’s not just you.

I just installed Sketchup Pro specifically so that I could use Flattery, and I’m experiencing exactly the same thing. Zapping everything back to a (should be) virgin state and starting with a fresh model in Sketchup, I can reliably unfold most, or all of the model. Try it a second time, and it crashes within a few clicks of unfolding. (Possible difference, I can only sometimes unfold all of a model, even with everything virgin. I do get crashes even on the first model, but it’s after many more clicks than any subsequent model).

I don’t know if this is “normal” behavior since I’ve never used Flattery or Sketchup before, but, only the “label the edges” button the the Flattery toolbar visibly responds to being clicked for me. It toggles “down”, and never comes up. The “unfold faces” button doesn’t provide a visual response, but when clicked on, it does put Sketchup into the unfold mode. Could be completely normal behavior, but, thought that might possibly give some clue into some code branch that’s not being traversed properly.

Thank you for the report. This is not typical behavior, @someguysfarm , I have been using SU and Flattery together since 2010 or 11. Prior to 2016, I could unfold very complex models for CNC or other ‘flattened’ production processes. If you can install the trial of SU Pro 2015, you should have a much easier time @someguysfarm .

I hope a solution can be found soon, my classes start in a couple of weeks. If a solution is not found soon, I guess I will buy a lab license for 2015.

I found time to install flattery on v16 and also had a bugsplat with second attempting a different model…

@Barry the report is Crash Report #39985

I suspect it’s a Ruby 2 issue, but will need to dig deeper…

john

1 Like

I only ‘regularized’ the original author’s Flattery to work in newer SketchUp versions…
I suspect that these issues are appearing in SketchUp on MACs ?

On a PC every executed SketchUp instance is separate.
On a MC there is only one application running - so I suspect that there’s some error - in perhaps referencing the active_model ?

I’ll have a look…

I think it’s the globals, which don’t actually seem to be reused…

and possibly an empty selection…

john