Flat plane appearing above existing geometry


#1

In this model, I have added trusses to an existing roof and then drawn a flat plane on top of the trusses which will eventually act as the new roof covering:

As you can see the trusses are visible “through” the new roof covering. At different zoom levels, the trusses sometimes disappear, and sometimes seem to ‘gradually’ appear through the length of the truss.

How do I make the plan always appear above the trusses - is it because it’s a flat plane and I must push/pull at least 1mm?


#2

Yes the lines are showing through because they occupy the same space as your plane. You can give your plane thickness or hide the lines of the trusses to avoid this. See below.


#3

A single face has no thickness so you need to either provide a gap or make it 3D. Keep in mind even with a short distance between the trusses and the plane, as you zoom out the trusses will come into view. That’s due to the relatively small distance between faces and the longer distance to the camera and the way OpenGL works.

The best solution for preventing the trusses from showing when you don’t want to see them is to put them on a layer that gets turned off when it isn’t needed.


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.