Flat Faces keep getting TRIANGULATED! making any time I extrude IMPOSSIBLE


#1

hey guys I was making a floor plan than I decided to draw a line on top of the the wall than rotate that one line to 60 degrees… after I tried extruding a wall not even touching it showed up as triangulated faces instead of a flat face, PLEASE HELP!!! it’s driving me NUTZ!!


#2

Why did you decide to do that?

Turn on hidden geometry and erase the unneeded edges. If you haven’t managed to get the edges out of planarity, the faces should remain.

All of your faces appear to be reversed and the orientation needs to be corrected.


#4

Well, from what little I can see in your screen shot, that rotation did cause a problem. I expect that while you rotated one edge, you didn’t rotate other edges on which the face is dependent so it got triangulated to maintain faces.

Looks like an interesting house model. Why is it below the axes? Do you just do these house models for the fun of it?


#7

Must be doing something wrong, then. That’s not the usual way it works. Can you show an example?


#10

Ahhh… Model partially below the ground plane. Shadows on the ground plane. Just turn off Shadows on ground and those shadows will be gone.


#11

that’s the thing… shadows add to the realism so I prefer keeping them on…


#12

I didn’t say turn off the shadows.


#13

dude you’re being uber rude


#14

you said turn shadows off the ground but then that would probably get rid of the shadows on the house as well I like to have the shadows on the ground as well I solved my own problem years ago by simply putting my models below the axises plaine field


#15

OK. Leave your model way below the ground and don’t try turning off Shadows on ground.


#16

It won’t. Try it.


#18

There technically IS a ground. It’s the default location of the red and green axes. That’s where those shadows you call blobs are projected.


#20

No I’m not. I was trying to help you. Evidently you don’t want it. My apologies.


#21

thank you sorry the picture you sent didn’t upload quick enough but I get what you’re saying … thanks for the help tho


#22

You will have to redraw this section. One or more edge lines is not perfectly straight, either parallel or perpendicular to the other lines.

I run into this sometimes as well. The only fix is to redraw.


#23

Sometimes when something is almost planar SketchUp can’t really make up it’s mind whether it is or not. I’ve also had faces that first are planar but then suddenly gets triangulated. As bkilburn said redrawing it is the only option.


#24

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.