How to fix triangulated faces?


#1

How can I fix this triangulated face?

I’m drawing walls under a gable roof.

I pushpull the complete wall to the maximum height and then use a circle to cut a 45 degree angle on the walls.
After that I use intersect faces with selection (wall + circle selected) and delete what can be deleted.

My walls look great, but it isn’t a solid anymore.

All the faces are triangulated, see attachment.
I can’t push pull these objects anymore.

What went wrong and how can I fix this?

thanks


#2

Would you be able to upload the skp file for us to investigate?


#3

At some stage in your process, you caused the corner points of your roof parts to become non-planar. A SketchUp face must be planar, so SketchUp automatically triangulated the roof parts for you. This might be inherent in the geometry you are creating (can’t tell without a model) or might be a result of your process. Since circles in SketchUp are actually many-segment polygons, use of them to create your 45 degree cuts is a likely suspect. It would be better to draw 45 degree sloped faces and intersect with them instead.


#4

Solved! I had to unhide the whole model. Somehow the settings changed… No I deleted the hidden lines.
Thanks!


#5

Well, SketchUp must have put these hidden lines there “for a reason”, probably to let you know that the triangles on either side of the diagonals aren’t coplanar. But, as it seems, all within tolerance. So then allowing you to delete them. But the problem still exists (not coplanar) and might come back with new hidden lines when adding geometry.
You must either be sure you solved the problem or correct the geometry to be coplanar.