Broken/Triangulated surfaces

I have this problem where a flat surface is broken. I tried redrawing the plane but it always come back. SEE SCREENSHOT>

The problem could be Z-Fighting … overlapping coplanar faces.
The problem could be compounded by faces in different contexts.
The problem could be compounded further by noncoplanar faces in different contexts.

Sharing the model file will help us help you.

1 Like

Still one possibility: If there are no overlapping coplanar faces, your model might lie very far from the model origin or have some unintentional geometry very far from the actual model.

2 Likes

Using the Draw>Rectangle tool, I re-drew the plane a few times to no avail. Finally I turned ON Show Hidden Geometry, deleted the triangular lines and that solved it. I think the problem was a corrupt line.
Thanks for the input. Hope this thread helps someone else.

I’ve been through this myself, though not for a few years now. I think it’s something about imperceptible out of plane geometry, and you’re right, there’s something corrupted in the file that’s hard to escape from once it’s there. Eventually, the only way I fixed the couple models this happened to was to disassemble the model and reassemble the model in a new file, or hollowed out copy of the original file. By that I mean, duplicate or save a copy of the file and then delete everything in it and purge all the libraries. Then start copying parts bit by bit back into it.

One habit I’ve changed since seeing this problem is keeping all loose geometry (raw lines and edges) on Layer 0/Untagged. It could be that some edit somewhere along the line on hidden geometry caused this, but I don’t really know why. Another work habit I’ve changed was not using dwg imported lines for modeling from, but rather only using them as a tracing guide to redraw shapes from. Again, it’s not clear why imported dwg linework might contribute to this problem, but I’m not seeing this problem lately. Sorry, these last observations are only anecdotal, but someone else here might have more insight.

1 Like

I made a few tests.
I took the corrupted co-planar surface to a new blank drawing.Copy>Paste in place.
I drew a new plane over it with the Draw>Rectangle tool using it’s 4 corners.
STILL!!!Same problem. So I narrowed the problem down to ONE of the the 4 lines that defined the plane… The corrupted line problem was imperceptible to SKP purge/fix problems, CleanUp3 plug In, and Solid Inspector plugin.
I erased the corrupted line, redrew it and the problem was solved.
But I learned…quick solution=Show hidden geometry> delete triangular lines.

1 Like

Check Model Info/Units do you have Enable Length Snapping ticked?
I’m pretty sure you will find that you do.
Best option is to untick it permanently.