Fixing install

Continuing the discussion from SketchUp 2016 is here!:

Heya Dave,

I’m hoping that I can pull though again and help tackle this hurdle as well :wink:

Give this utility a try : http://support.microsoft.com/mats/program_install_and_uninstall

Heya Dave,

I'm hoping that I can pull though again and help tackle this hurdle as well :wink:

Give this utility a try : http://support.microsoft.com/mats/program_install_and_uninstall

  Hey Tommy,


  Man, I've got to give you credit for sticking with me! You are a
  great ambassador for Trimble/Sketchup. I ran the software and it
  "did not detect any problems and therefore no fixes were applied".
  I'm beginning to think that my laptop needs an exorcism...hah-hah!





  I really like my Win 7 and so keep it in pretty good shape with
  updates, virus protection, etc. Perhaps it is something inherent
  in my Toshiba/AMD laptop that doesn't play well with Sketchup
  2016. Up until now, I've had no problems updating from year to
  year. I understand that your bag of tricks is not bottomless, but
  I will stick with you as long as you are willing. 




Best regards,

Haha. Many thanks for your kind words, Dave :blush:

Actually, my bag of tricks (at the moment) is indeed empty. But I call upon the great and powerful @andrew for his thoughts on the following error you’re seeing when installing SketchUp Make 2016:

Hi, Dave,

We have not modified the relevant portion of the installer for several years and I’ve never heard of this problem before, so we’re in new territory. Though I can’t be certain of what’s happening, I have a guess.

Since you’re already running the installer as an administrator, there must be a problem with the permissions inside the registry such that your administrator account does not have permission to modify the affected key. We must resolve this error before the Windows Installer service will allow the installation to complete.

Adjusting registry permissions to fix this directly is a pain. Instead, let’s assume the broken permissions are limited to the one key the message cites, which we will delete rather than trying to repair. If that assumption is correct, when we re-run the installer, the new key will be created correctly. Since our installer is responsible for creating that key, it’s safe for us to delete it.

Here’s what you need to do.

Since you might not be comfortable making registry changes by-hand, I’ve written a registry script whose sole function is to remove the “style.Document” key from the registry, which is the specific one giving you problems.

  • Download this attachment: del_style_doc_key.zip (279 Bytes)
  • Open the ZIP file and see that it contains a single “.reg” file.
  • Extract the “.reg” file from the ZIP, saving it to disk.
  • Double-click on the newly extracted “.reg” file to execute it.
  • Windows will warn you that executing the script will modify the registry. Accept this warning.
  • If the script executes successfully, Windows will report that it successfully added the included keys to the registry (even though the key was really deleted).
  • When that’s all done, re-run our installer and cross your fingers.
  • If the installer fails again citing the same location, it means the parent key’s permissions are bad, which will require manual repair.
  • If the installer fails again with a different key, it means we solved the problem for “style.Document”, but more problems still exist, which we can then address separately.

If you’re willing to trust this procedure, please give it a shot and report back with your results.

Thanks!

Andrew

Edit – Note for future searchers.

The heart of this issue is running the installer as an administrator, but seeing a registry permission error like this:

In this case, Dave’s problem was solved by removing the the “style.Document” key, because that’s the one that had bad permissions. Those who have a similar problem in the future may be able to solve it the same way, but would not be able to use the included script, since it’s only designed to fix the “style.Document” key.

In such a case, I would suggest you post a follow-up to this issue asking about how to handle your specific case and seeing if you can get some assistance before blindly editing the registry. Not all keys are as safe to delete as that one was. Plus, editing the registry is tricky business and doing it incorrectly can have serious, system-wide consequences.

2 Likes

Andrew,
Thanks so much for sharing your expertise; it worked! I ran your .reg file and then was able to install Sketchup 2016 with no problem. You and Tommy stuck with me even though I’m not a power user. You’re winning hearts and minds…

Thanks
Dave

1 Like

Hi, Dave,

I’m so glad to have been of assistance. If your problem is fixed, please mark my previous post as the solution so the issue will show as solved for those who search in the future.

Thanks, and happy sketching!

Andrew

This is the post that solved my problem and made it possible to install Sketchup 2016 on my computer. Andrew and Tommy were relentless until they had a solution. Thanks, guys!

Dave

good morning folks we have a pc with a quadro k620 2gb display ram w7 Pro and we cant get it to install. I installed it on my pc with ati and 1gb display ram

it fails trying to write to the registry:

Sketchup Pro 2016 (64 bit) Setup

! Could not open key:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION. Verify that you have sufficient access to that key, or contact your support personnel.

[ OK ]

What’s next please? We tried the microsoft fixit tool to no avail.

Thanks leon

Are you running the installer as admin?

YES as per the notes above

we’re sort of under the gun as we need to craft some diagrams and can’t move forward with this :frowning:
Thanks leon

What if you try to install the 32-bit version of SketchUp Pro?

If there’s an issue with the installer, there’s a utility from Microsoft that could do the trick:

http://support.microsoft.com/mats/program_install_and_uninstall

1 Like

32 bit does same thing

If you go into the registry, can you see what that key is set to? This will help us to figure out what it is trying to do vs why it isn’t working.

On a side note, are you logged into the computer in an admin account?

Hi guys!

I just tried installing the 2018 pro on my windows 7 computer and received the similar error message that Dave received, except mine says “sketchup.document” rather than “style.document”.

I tried running the “.reg” file you made for Dave until I realized it was specific to his “style.document” issue. Any chance “sketchup.document” can also be resolved with similar “.reg” file?

Thanks a million!

Christine

Dear almighty sketchup community (@ty_s @andrew @Tommy)

…can anyone help with this as soon as possible? I’m trying to get this set up for a class next week. Hoping to resolve this before the class starts.

Thank you!

Christine

Can you upload a screenshot of the error message?

Are you running the 64-bit version of Windows 7 Also, which Nvidia graphics card does your system have?

This appears to be a permissions issue we run into on occasion. Please see the steps found at this site for instructions on how to resolve it: http://www.okino.com/conv/changing_windows_registry_permissions.htm

Lovely! I will give this a shot tonight and report back!

Thank you!!

The error message is basically exactly what Dave had, except where his said “style.document” mine said “sketchup.document”. I am running a 64-bit version. Not sure about the graphics card though. Will have to check and get back to you. I am hoping what Tyrel suggested will work! Giving it a go tonight. :slight_smile:

Thank you!