Find Unused Components

I’m pretty new to SketchUp but I’ve been doing a lot of practicing. I am using the free web version. I have a few problems that have been bugging me but this is the first:

In my Components panel, I have a couple of different components showing up in my Components panel which I don’t think I am using and I can’t find them. I want to be sure that I’m not using them and delete them from the model. I can drag them in from Components and then delete them but that does not work. When I do drag one in and show the component information it always shows that there are at least two of them are in the model. Any ideas?

I’ll throw this problem in as it may be related: I have had a couple of components for which I have discovered “geometry” which is separated from the container(?) of the component, i.e. the expected visible part of the component.

Thanks for the response and the tip @dezmo . I have tried the purge button more than once but the components remain. It makes me think that they must be in the model somewhere but I’ve tried hard to find them, without success.

You can use Outliner to locate the component instances, delete them all, then you can purge the component definition.

Thanks, @dezmo, for giving me my first look at the Outliner in action! Since I am using the free web version I don’t have access to that feature; it may be the only SketchUp feature for which I’m willing to part with the annual $350 subscription.

I’m going to create a test project and see if I can replicate the problem in a simpler environment.

It is also part of Go plan, however the desktop version have more features…

Hi @pspringer57, thanks for the post. It is possible that the component that is refusing to be purged is inside a different component or group. If you only have a few components or groups, you might be able to go through them all to purge it but it will be a bit boring. Of course it might take a lot longer if you have a lot of components or groups to go through and at that point, Outliner is definitely the way to go.

Thanks @CaseyG . I don’t know what you mean by this. Is the idea to select a component or group and somehow see what it contains?

Thanks @dezmo, I thought it was not included with Go but apparently I had bad information. Darn ChatGPT! :face_with_diagonal_mouth:

Components and groups can be like nesting dolls. In addition to lines and planes components and groups can be made up of other components and groups.

Double click a component to edit it (open the outer nesting doll) then start exploring what’s inside.

1 Like

Thanks @bmike , I’ll try looking at my groups and components that way. Although it’s a little harder with groups - I assume that Outliner might identify groups for me.

Since AI s aren’t really intelligent (just fucking fast algorithms, with a fucking good marketing), these have no idea what these’re talking about, so these lie so unabashedly that you can’t even imagine…


Can you upload your model to the forum?

Then someone can look at it for you.

@john_mcclenahan , I just saw your suggestion and I’ll look into that. For now, though I had just taken a screenshot of something I think is possibly related to the missing component problem but different. A few of my components show this evidence of separated “geometry” from whatever you call the other part of the component. I don’t know how this happened or whether it can be fixed. I’ll delete them and create new ones if necessary but there is a bit of joinery in some of them that I’d rather not re-create if I don’t need to.

Any ideas about this? It is a single component with a “shadow” part that appears when I unhide geometry.

You’ve hidden an instance of the component. Right click on the mesh version and choose Unhide. Or, do you get a single bounding box encompassing both when you select the one on the left?

It is much easier to help you if you also share the .skp file with us so we don’t have to guess at what we can’t see in the screenshot.

This is what I see.

That is next on my list @DaveR , thanks.

Then another guess. You copied the geometry within the component instead of copying the component and then hid the geometry.

Well, I see that I cannot save this file to my computer (it is on the Trimble server) nor can I export a .skp file. This is frustrating because I started the model in my wife’s free account and now that I have my own (free) account I don’t see a way to move the project. I suppose it doesn’t really matter. But the only way I can see to show you my work is to share this copied link - I don’t know what that allows you to do.

If you spend any time (more than 30 seconds!) looking at my model I’m sure you’ll see many, many things I could have done better. Tips are welcome. Here is the link:

My model on a Trimble server

You can download the model file to your computer. As it is, you’ve only shared a link to view the model. Although I can select and open the component for editing I can’t make any modificaations. Open the component for editing andselect the hidden geometry. Then press the Delete key.

Okay, @DaveR I was able to delete all (I think) of those mesh versions of my components. I also see that the component I could not find has been removed from the component list. I’m not sure when that happened but it’s gone.

And I saw how I could download a .skp file of my model. I opened it in my own account and noticed that I can’t save locally, just download. Saving apparently must be done to the Trimble server.

So I am going to upload my file, just for the experience of it. I think that with the help of the forum members, all of my known problems have been resolved. I’m sure that I’ll have more soon!

Thanks all!

Single Door Cabinet.skp (1.4 MB)