File will not print

My file will no longer print. Older saved copies are fine. New files are fine.
When I click Print in this file, the print dialog doesn’t open. Instead a blank field covers part of the screen in its place. It is then necessary to force quit. I have tried duplicating the file. I have tried opening a new empty file and pasting the model into it. No luck with either. Any ideas would be appreciated. 2008 Free version

Try (1):
Make a copy of the file.
Open the copy.
Purge all unused,:
ModelInfo > Statistics click “Purge Unused” button.
Save and try Printing.

Open the file in SketchUp (1).
View > Hidden Geometry
Camera > Zoom Extents
Edit > Select All
Start another instance of SketchUp if on PC.
Switch back to the app instance (1).
CTRL+C or Edit > Copy
Switch back to the empty app instance (2).
CTRL+V or Edit > Paste
try to print from the copied app instance.

Thank you DanR. No success w/ either option, although I am on a Mac and can’t open a 2nd instance, as far as I know. Tried #2 w/ just a new empty file.

On Mac, you have a multi-document interface. Replace “instance” in your mind with “new document window”.

Other than that,… I jave no Mac, so all I can suggest is be sure the printer is on, online, you have drivers installed, and your system can “see” it.

Can you share the problem file so team members or Mac gurus can try it on their machines ?

Thanks Dan R. I did the new doc window - no luck. My solution was to download the 2016 Pro. The copy printed fine in that. Possibly downloading the newest Make would have done it also. From this I would infer that the file would work on another’s system. Who knows why. :neutral_face: Over and out.

SketchUp v8 (01.09.2010) was released for Mac OS X v10.5 and obviously not for recent versions of OSX.

another thing with OSX users, never copy from an old system to a new one but do a real program installation only.

Do you mean: do not use an outdated version of SketchUp with an OS X upgrade? Or do not copy a file from, say SketchUp 2008 on OS 10.5 to 2016 on 10.10?

the system requirements of applications typically do not cover operating systems released in the future… this does not mean, that the applications does not run but nobody can and will guarantee this.

copying a program folder from an old system to a new system was common in those days as applications did reside in a directory only, with modern applications accompanied by e.g. third party frameworks a ‘real’ program installation by running a setup routine is regularly required… at least for a program installation as intended by the maker.

Thanks for the insight.

I would add, that using System Update and System Upgrade to migrate all your apps is very good on a mac…

OS X will actually disable any that fall below current System requirements and show them crossed…

i.e. SUv5 stopped working 3 or 4 OS X’s ago, but I still keep a copy for nostalgia…

also, SU has always re-generated any missing folders every time it is run and I have never experienced any issues with using any of the older [not yet crossed] versions on any OS X upgrade…


I really am a beginner, my first version was SU8.

issues do typically arise in the area of user permissions if simply copying folders, but a fresh installation doesn’t harm anyhow.

I still have my V3 disk somewhere…

And I have a V2 disk, even though I got that when I bought a bundle of ArtLantis and SU from the “surplus basket” of a software reseller when i alredy had V3.

Mac OS is notoriously non-backward compatible, and the reason I once switched to PC was that to get a working Internet browser I would have had to buy a new computer and new versions of all my software, even though I was quite content otherwise with the Macs I owned. In my old XP laptop that I scrapped some time ago I could happily run all SU versions from V3 to 2014.