File not found or invalid file

Hi, I was working on a file from past few days and suddenly my file crashed, and now when iam trying to open autosaved file. it says file not found or invalid file. Can some please help me

What happens when you try to open the file itself, not the autosave version?

• Where was the original file located when you opened it?


• Do you save files to your local disc?
• Or, are you opening and saving files to a storage / synchronization service like Drive, Dropbox or OneDrive.

Now I’ve been getting this. All saved locally, normally. I am getting short on disk space.39%20PM

opening from where and how?

I only get that if I move, rename or trash a file and then use ‘open recents’…

I also get it when I ‘lock’ a skp file to prevent further changes…

opening directly in Finder usually will open any of those…

and not alway then…

john

The original and the ~backup file do this as well as a Save As… copy that was supposed to be version 18 give this error. I used Time machine to go back a few hours and that file gives the error. I transferred the file to a different machine with plenty of space and still got the same error.

This is now a major problem.

I went back to a previous generation of the file and was able to open it, redo my work, save and close as a new file. As soon as I come back to reopen this file, again the error.

I’ve put in an official support ticket and haven’t heard anything yet.

The problem file is a site model with a proposed building inserted as a component. I have isolated the problem to the “reloaded” building component. This technique has worked fine up until my latest building iteration. The source file for the building component opens, saves, and reopens fine, but inserting the building component into another filed is poison and renders that file unopenable.

One difference in this iteration is the building now includes a Medeek complex roof construction in it. It will take more experimenting to isolate parts as the cause.

In the support department there are a few of us who take a wide range of support tickets, and a couple of us who mainly take the tougher cases. One of those two is handling your case, but I also tried the file.

What you said about Medeek gave me an idea, which I’m trying. As far as I can tell, the Medeek plugin is only ever tested with Make 2017, and so I’m doing a test of using Open Newer Version to open your file in Make 2017. It isn’t working out great just yet, the extension is still trying to convert the file, and shows a “not responding” message. I’ll give it more time.

Another file I’ve been testing crashes 2019, but I find that it opens ok in 2017. I was hoping your file would be similar.

1 Like

I just looked at Open Newer Version and realized it’s Windows only.

I just tried deleting the Medeek Roof assembly and one possible other component that I experienced a bug while editing, purged components and layers, and saved out the building component to disk. Reloaded that building component from disk into the site, saved and tried reopening and still get the same error. Rats!

I can send you the building file and component as a separate file to look at.

Hi, I accidentally deleted a file. Got it back using Disk Drill but got this error. Did I lose my work? Please I desperately need help.

Very possibly. I’ve seen reports of others having corrupted files after using some sort of disk recovery software to get files back. (Not just SketchUp files.) Had you emptied the trash after deleting the file? If not, did you try just moving the file out of the trash? Did you look for the backup version of the file or did you delete it, too? You could upload the file here so someone can take a look to see if there’s any possibility of fixing it. If it’s time sensitive, though, it would probably be a good idea to get busy making it again.

Particularly for binary files such as SketchUp’s, recovery software is hit-or-miss - even if you have saved nothing since. Recovery relies on educated guesses about where each part of the file originally lived on the disk and in what order they should be reassembled. Sometimes you get lucky and they were sequential on the disk, hence easy to recover. But other times they were scattered around and recovery is impossible. Binary makes it harder because there are no clues about how one fragment flows into the next, the way there may be with text.

1 Like

I have received a message that he is now getting personal in a (private ) facebook group ‘Sketchup France’ .

Does anyone has access to that group?

Hi Colin, I also have the same problem, “File not found or invalid.” But I see the preview of it in my mac. Can you help me open it?

I am on a plane at the moment. If you upload the file somewhere and give the link in your next post, I can look at it when I get home.

Hi Colin, i have the same problem. Here is the wetransfer link, would you able to help me out please?
https://we.tl/t-ApwMGQX8s3

I don’t see anything in the scene, but the file size is close to the original, which makes me hopeful that you used a lot of components that you could rebuild the scene from:

https://we.tl/t-KL6mBA7wrj

Can u please help me with my file too?

You would need to share the file in order to get help with it.

Are you actually using SketchUp Free web?