Failure to Launch Pro 2019 Paid download

Continuing the discussion from Thanks for spending time with us:

I have a case # 10307218 from help, but no response, so looking for another avenue of help, I am running Windows 10. Downloads, sketchup shows as active, but still shows I need to download. Already tried:

  1. Logging out and back in.
  2. Repairing installation
  3. Deactivating all users (even though I am only user, with only 1 computer
  4. Uninstalling and reinstalling.

I’m open to all suggestions.

Subscription or Classic license ?

Subscription.

What exactly does the screen look like when you try to open SketchUp? Can you share a screen shot of what you see when you try to launch SketchUp?

It takes me back to my plan screen. The free version has a launch box, but the Pro version only has a download box.

That page comes up when you try to start SketchUp?

Did you install SketchUp 2019 correctly? That is, did you right click on the downloaded installer and choose Run as administrator?

Maybe not. I hit download, then run and walked through the wizard steps. I don’t recall if it said run as administrator. I will uninstall and try it again watching for those things. I’ll let you know the outcome.

No! Don’t uninstall. Just find the installer or download it again. Then right click on it, choose Run as administrator and when prompted, choose Repair.

Do you have 19.3 already? If not, download a fresh copy of the installer from sketchup.com/download/all

I downloaded 19.3, although I’m pretty sure that was what was downloaded the first time. The installer came up, but there was no option to “Run as Administrator” when I right clicked. It only allowed me to hit the run button. I ran the repair option, which I had done previously, but still nothing has changed.

Is it possible a setting on my computer is not allowing the download, even though it shows it is installed?

Did you right click on the downloaded installer for SU2019.3?

Screenshot - 1_23_2020 , 5_26_11 PM

I never reached this screen and not sure the path to get there, or even the SketchUpPro-2019-en.exe screen that is behind it.

I only right clicked on the file name in the Downloads folder to get that. The SketchUpPro-2019-en.exe is the name of the downloaded SketchUp file.

I 'd be happy to try to help you but I’m on my way out the door for the evening. You should remove your phone number as this is a public forum and anyone can get it.

I could help you on Friday morning–CST.

That would be great. Earlier the better. I will be traveling to a meeting after 9:30am CST. Thank you

We did a screen share to see what was going wrong. The problem was that having used Free and Shop for a while, and opening them from the account page by clicking on Launch, the expectation was that Pro would also be opened the same way. Clicking on the button in the account page would download and run the installer again, and not actually launch Pro.

So, 2019.3 had been successfully installed the first time around. The browser was running maximized, and so it wouldn’t have been noticeable when the shortcuts were added to the desktop. When I opened it I used the Windows search box, and didn’t have to minimize things to see the shortcuts.

There were other oddities to figure out too, one being that the model worked on during the Shop days was not showing up in Trimble Connect, but was showing on the Home screen as a recent file. I couldn’t see in Shop how you publish to Trimble Connect, so instead I downloaded the SKP, then uploaded that to Trimble Connect.

Maybe someone can tell me a more direct way to get a model from Shop to TC.

Thank you Colin for all of your help. Doubly appreciated because I’m sure staying to help me made for an extra long day. :slightly_smiling_face:

I was working at home today, so the commute wasn’t too bad.

Adding a launch button to that page (ie. Launch Desktop Client) catches two flies:
You are all ready signed in with the right Trimble ID
You do not have to go back and forth

Especially when logged in in other devices, you might have to:
Start up Sketchup
(Opens browser tab to sign in)
SketchUp says ‘Too many Devices, manage subscription
(Open new browser tab with AMP, click deauthorize)
Come back in SketchUp, the login needs to be triggered, so you would have to sign out, first
(Opens a new tab in the browser to sign out)
Go back to SketchUp, sign in
(Opens a tab in the browser to sign in)

At that time, I have forgotten why I even tried to start SketchUp in the first place…