Extension Warehouse Timeout Error ALL THE TIME


#1

Topic says it all. I can’t update any of my extensions, and I can barely even browse. I get timeout errors all the time. If I browse the EW from Safari, I am ok.

I am using a Mac, latest version (Sierra), and this error happens with 2016 and 2017 (haven’t tried other versions, no time for this). I’ve logged out of my account and back in (using a google account), but no help. This has been going on for weeks now.

Other relevant info: I am in Thailand, not sure if that affects this. Odd that I can use EW fine via browser, but not from within SU. Any help appreciated!


#2

I had this problem on PC. Its because I hadn’t updated Internet Explorer. Apparently the latest system runs on Chromium. I don’t have Chromium, but use Chrome. All seems to work. Hopefully this helps.


#3

You don’t need to have Chromium as such. SU 2017 ships with the Chromium library bundled into the app and uses it for many purposes instead of your system or default browser. This will eventually get rid of all the problems with variations in local browser settings because SU will control its own library. In the near term, there are still a few items that rely on your system’s browser, and they can still cause issues. I’m sure the Trimble team are hard at work eliminating the remaining gaps.


#4

So…just wait? I can’t update any extensions now, and even downloading/searching new ones has the problem most times.


#5

Can you logout in SU 2017 and login again using a new Trimble account to connect?

-Nick


#6

I did that many times. However, odd thing. I went overseas for business and tried again, and now I can login/update my extensions fine. No idea if it is related or just luck. For now things are ok. When I get back home I’ll try again and see if the problem comes up again.