Extension Warehouse lockout

in use here: Chrome Browser and LastPass. Have in the semi-distant past had Safari as my main browser (3 months ago).

Signing into the extension warehouse via SketchUp is typically hit and miss for me.

Lately it’s been more problematic than not… And I find this amazing because I use a password manager, I haven’t changed anything,… and it’s not a matter of forgetting something.

But still I’ve been stonewalled at the Sign In Window for the last couple of weeks or so.

Just now, in an effort to sign up for a developers account, I easily made it through the Sign In Page… and was able to fill out the application form.

Both of these sign in screens are asking for the same account info… I can sign in with a Trimble Account or my Gmail account.

Admittedly, the straight browser path to the developer site, does play better with my password manager, than the in app sign in page that SU pulls up for the EW site. with the in app SU login to EW… I always have to copy/paste my password in. (where sometimes it takes, and often it doesn’t). And of course signing into the SU Developers site all of the autofill stuff works in the expected manner.

So what’s the problem with the SU to EW sign in method… why is that so unreliable.

I already take extra caution so as to not copy/paste password info multiple times, making sure to clear the fields out beforehand… and, as an alternative approach I’ll also try manually typing everything in.

The same info is going into both sites… why the different outcome between them?

maybe this is the issue?.. Could it be that SU is still using Safari? and that’s put some odd conflict into play…

Never thought to check on this… but I’ll now go and look if there are settings that need to be adjusted independently for SU.

I did make Chrome my default browser as far as the OS is concerned. but I pretty much stopped with just doing that.

You could have added such relevant info as your Sketchup version.
The wording “default browser” does not really describe it well. What SketchUp versions before 2017 were using is the operating system’s included browser engine (totally independent from user preference). SketchUp 2017 and later bring their own browser engine based on Chromium, so it is not influenced anymore by the operating system’s settings, versions and bugs or the environment outside SketchUp.

Sorry, I’m asking myself the same because I did not yet really understand your question. Can you rewrite the relevant question in a short and structured way?

Have you tried clearing the browser cache?
Windows: C:\Users\<username>\AppData\Roaming\SketchUp\SketchUp 2018\WebCache
macOS: /Users/<username>/Library/Application Support/SketchUp 2018/WebCache

1 Like


I’m using 2018 Pro and OS X 10.10.5

… So, I guess there is no need to clear the browser cache if SU’s Chromium solution operates outside of those influences??.. but even if there was—I did that a couple of days ago anyhow.

Of the two ways I can sign into the SketchUp Extension Site:

Going to… https://extensions.sketchup.com, with my regular browser works perfectly well.

but signing into the site using SketchUp’s independent browser solution Often Fails… and lately, for the vast majority of the time, I can’t sign in at all.

It DOES sometimes work. Averaged out, I’d say 80% is a fail… and the remaining 20% is good.

The sign in info is the same on my end… I would expect that either path the EW would allow equal access.

Thank You for the info about SU’s in house browser solution… That’s nice to know whether I have it working or not.

Did you clear all files in the browser cache of SketchUp’s browser engine (directory given in the above post)? Does the issue then still happen?

Ahhh, I’m sorry @Aerilius. … No not yet.

I’m heading out and was shutting things down… but I wanted to send off a reply to fill in the missing info I had left you with.

I’ll do this just as soon as I get back… but it will be a while until I can return (~ 8 hours or so).

Thanks for all the nice info you’ve already supplied me with… I’m glad to learn about that.

Take Care,


Hi @Aerilius

I am now able to sign in again, Thanks to following your advice.
It did take three sign-in attempts before I got through… but I can live with that.

If/when things get worse then I’ll go and clear out the WebCache again… as it seems to have helped.

First and foremost, Thank You for putting up with me… and Thanks again for the insights.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.