Can't sign into SketchUp


#1

Hi,

I am having problems signing into sketchup, a new window opens but its just blank.
same thing happens when i try to export an stl file or try to download an extension
any help would be much appriciated.

Thanks


#2

sorry, I read this thread wrong: thought it was the typical question. On sign in, you should be getting an OAuth panel from Google to sign in. Can you try signing into gmail on IE/PC or Safari/Mac?


#3

Where do you try to sign into SketchUp?

Maybe this can help you?


#4

Hi
I have cleared cache and history but this didn’t help, I am running Firefox
on windows 7.
I am signed into google and Gmail and both are working fine (I have also
tried when logged out) but this didn’t help either.

I am new to sketchup (and computers),it also happens when I try to sign
into extension warehouse

Thanks for your replies.


#5

SketchUp uses MS Internet Explorer on the PC for it’s webdialogs.
Update to the latest version of IE 11, do all updates to Internet Explorer via Windows Update.


#6

So are you using SketchUp or Firefox to access? If it’s SketchUp, it’s using embedded IE, so you need to clear IE cache, and delete cookiejar.xml and session.dat (search the forums for this). If you’re using firefox, go to https://3dwarehouse.sketchup.com and if it doesn’t render, you probably have javascript disabled.


#7

Thanks guys,
I’m not at the pc at the moment, when I’m back online I will check out your suggestions and let you know how it goes


#8

@ddamiensu - Were you able to fix this issue?

I am having the same issue. When accessing extension wharehouse the window that opens displays most of the graphics and text but not all as you can see in image below. The big red button should have text on it. When trying to login from same window by clicking “Sign in” it just displays a blank window. None of the suggestions above worked for me. This is a fresh install and I have updated my display drives.


#9

Hi,
No I have tried the above too, I think it might be an issue with Java, I’m trying to work on it at the moment.
I’ll let you know if I sort it out


#10

I just updated Java yesterday.
Also, this issue happens with almost every pop-up window in SketchUp 2015. Here are some examples. There just… blank.


#11

Java and javascript are two completely different languages…

you need to check that javascript is enabled…

john


#12

Yes, I have checked and Java is enabled.

Also, I tried what is suggested (see image below) in this article: http://help.sketchup.com/en/article/3000056
I was denied access while trying to save the file. Not that this article had anything to do with the issue but I thought it a little funny that I was denied access.
Another issue that I have and am assuming is related to this. When viewing “My Extensions” on the web, site some of the extensions I added in SketchUp through “Preferences” are not on “My Extensions” list.


#13

You are correct, this has nothing to do with the topic issue. It simply means you do not have the write permissions for the %ProgramFiles% path (hierarchy of directories.) The instructions are too generic and do not explain that Administrative priviliges (with write permissions) are required.

(@Tommy, the 1st path is only correct for 32-bit SketchUp on 64-bit Windows. The 2nd path is also correct for 32-bit SketchUp on 32-bit Windows.)


#14

No, this is not related either. If you wish to control extensions via the Extension Warehouse “My Extensions”, then you need to install the extensions from within SketchUp via the Extension Warehouse dialog.

SketchUp menu: Window > Extension Warehouse
… then reinstall those extensions you had installed manually.