Cannot sign in to 3D Warehouse, still

I’m a bit exhausted with the relentless sign-in difficulties. I’m often giving the standard advice to sign out and in again, or dump the browser cache, but this one has me stumped.

I am signed in and functioning in SketchUp and Layout, but 3D warehouse is not signed in. This happens when I open from inside SketchUp or if I use a web browser to access. In both cases the warehouse offers me the option to sign in, but when I attempt to it either goes blank or simply reloads the home page. I have signed out and in through SketchUp, through the Trimble ID website directly and I have cleared my browser cache, the problem persists.


Very strange. I don’t know what to suggest.

1 Like

The plot thickens: Now my 3D warehouse window actually opens SketchUp Free. I can actually model in SketchUp Free from within SketchUp Pro.

This is getting weird.


1 Like

Most of the times when things go awry, there are other apps interrupting like Antivirus/malware software.
Do you have any?

Thanks for the thought, I have no security running. This situation started on Jan 1st. I have tired deleting: Finder> Go> Hold the Option key> Library> Application support> SketchUp> SketchUpXXXX > WebCache

no love

I am locked out of extension warehouse, and 3D warehouse. Can’t get in on browser or through SketchUp. I tried a few browsers, all the same, browser window goes blank or returns to the home page without allowing me sign in. I’m about out of ideas here.

Interesting point, the same thing happens in iOS on my ipad. The app is signed in and operational, but when I access the warehouse it refuses to sign in. Leads me to believe this is a problem with my account?

@TheGuz @Elmtec-Adam @colin Anyone?

If it’s happening on your iPad , It is also a possibility like it’s something network related and a security certificate or something has expired.

It might perhaps try power cycling your Wi-Fi router/modem.
If you have a cell phone with it’s own data connection, you could try using that rather than your local network


Seriously though, that’s the weirdest thing I’ve seen on the forum so far. Next thing we know, you’ll post a gif of the offset tool scuttling off with your cursor.

1 Like

I am curious about the problem, but also at Heathrow Airport on my way back to Boulder. If I don’t have any new ideas I will chat with TheGuz tomorrow.

Strange how 3DW got pointed to @Gopal and @Mark may have ideas about that.

1 Like

This is getting to be a serious problem. I’m ready to believe that it’s a problem on my end, this situation exists on my 2 computers and my iPad, in the SketchUp app and on all 3 browsers that I have tried. All the same, I can sign into the app no problem but not the warehouses I have tried turning my firewall off, I’ve reset my router, i have tried using a different network to access the web. All the same , somehow the 3D warehouse and the Extension warehouse house are blocked for me from any access point.

Further testing: I can open SketchUp Shop and I appear to be logged in, however my previous saved models are gone, there no existing saved models when there should be many, but my Trimble connect folder structure and files are intact. If I try to access the 3D warehouse from within SketchUp for Web I get the following response. I’ve tried resetting all cookies and turning any security measures off but no luck so far.

Why are you on Are you conflating beta software with production software? The sign-in’s are separate.


I am not “on” any site. This message is what pops up when I attempt to access the 3D warehouse from within SketchUp free, the window that message is appearing in is the 3D warehouse pop up window. I am not part of any beta program that I know of.


You’re on a VPN - disconnect from that and try again.

Also, try a supported browser:

Can you please try to login first to and then try to login to SketchUp for Web using the same user? Trying to narrow down the problem.

Thank you,

Thanks for the thought, that was well spotted. My VPN is only for certain aspects of browsing and the settings have not changed in a long time, while this problem is 4 days old now. To be sure I disabled it and tried again with no change. I have tired from within SketchUp Pro, from within the SketchUp app for iOS, through SketchUp Free on different browsers and as a direct access web site through Chrome, Opera and Safari. On two different computers with different networks. All the same behavior.

I really appreciate everyone brainstorming options for me.

1 Like

Thanks for the suggestion and for helping me think this through.
I cannot login to the 3D warehouse, that is the essential problem. Any attempt to do so simply reloads the current page, I cannot access the login fields. This is true also for the Extension Warehouse, and true not matter how I access the Warehouse.


It’s going to be something weird like the clock is wrong on your router :sweat_smile:


ya, something not right on your side @endlessfix , browser settings, adblocker, system time settings, etc…

I agree, the problem must be here somewhere, But I’m stumped, it persists across multiple networks, multipel browsers, different operating systems. I did check the clock and it’s set by the server so seems correct.

Are you on a laptop? If so try connecting to a different network, like a friend’s.