Can't Sign In to SketchUp Warehouses


#1

This is a weird one: I have an old system, Win XP SP3 and MSIE 8, with SU 8, 2013 and 2014 installed. I can ONLY log in to the SketchUp Extension Warehouse through SU 2013. SU 8 of course doesn’t have access to the Extension Warehouse. When I click the 3D Warehouse “Sign In” link in SU 8 or SU 2013, or either the 3D Warehouse or Extension Warehouse “Sign In” link in SU 2014, they all give me the “This program cannot display the webpage” error screen (screenshot detail below). But SU 2013 seems to sign in to the Extension Warehouse (only) just fine. I was careful to sign out through SU 2013 before trying to sign in with 8 and '14. Also, I can’t sign in to either warehouse in MSIE outside of SketchUp - I get the very similar-looking “Internet Explorer cannot display the webpage” error screen. I don’t see how this could possibly be caused by Internet Explorer settings - wouldn’t they also stop SU 2013 from getting into the EW?. I’ve already cleared the MSIE cache and cookies, etc. and attempted to check any relevant security settings, though I’m not sure I found the right ones other than following step C on this page. What else can I do (other than getting a new computer)?


#2

Not so weird.

Heads-up, SketchUp 8 and SketchUp 2013 users!


#3

I already applied that fix. I can view the warehouse pages, but I can’t sign in (except the one way I described above). SU2014 is also affected by my issue but SU2014 is apparently not subject to the fix you linked.


#4

You will not be able to log in on 8 & 2013, only download. You will have to use a browser to log in.


#5

But what I’m saying is, my situation is different… I CAN log in to the Extension Warehouse (but not the 3D Warehouse) in SU 2013. But I CAN NOT log in to either warehouse (3D or Extension) in the IE browser outside of SU, and I can’t log in to either warehouse within SU 2014. So what’s going on here?


#6

The Extension Warehouse was released with SketchUp 2013 and was a new feature, after Google sold us in 2012. 3DWarehouse was released at Trimble with SketchUp 2014. Hope that explains it. It’s not easy to rip the guts of something out of one company and port it to another entirely different environment without the built-ins we got for free with Google internal infrastructure, so I hope you understand.

Your 2014 inability to login is unrelated. See http://help.sketchup.com/en/article/3000056


#7

One thing that article leaves out: try deleting session.dat and cookiejar.xml from your C:\home\your home directory/AppData/Roaming/SketchUp/SketchUp 2014/. If neither file is there, that’s not the problem.


#8

I found a “cookiejar.xml” in C:\Documents and Settings\<user name>\Application Data\SketchUp\SketchUp 2014\SketchUp and deleted it. I don’t seem to have any “Roaming” folders in Documents and Settings (nor anywhere else on my machine, for that matter). But I still can’t sign in to either warehouse in SU2014.

Then I tried something a little different: In SU '14 I went to File > 3D Warehouse > Share Model. The window below flashed on for a fraction of a second, then instantly went back to the familiar “This program cannot display the webpage” window. I don’t know if this info is helpful for diagnosis or not.


#9

That IS the roaming profile data on Windows 5.x, ie:
"%AppData%"
which also is:
%USERPROFILE%\Application Data

The local profile data on Windows 5.x is here:
"%USERPROFILE%\Local Settings\Application Data"
which in Windows 6+ has the variable %LocalAppData%

Ref:
Wikipedia: Windows file system directories
Wikipedia: Windows default Environment Variables


#10

No, that pages loads as quickly as possible, and checks for the user being logged in. If the user is not, it takes that page away. On really slow networks, it can hang around longer than we’d like.


#11

OK Barry and Dan, what’s the next step I need to take to diagnose this problem? BTW, thanks for sticking with me this far.


#12

Can you sign in using Internet Explorer? I’m guessing your IE security is cranked too tight: when you click on sign-in, the first site you go to is accounts.sketchup.com, which will in turn redirect you to Google’s OAuth page. That should be fairly straight forward. 2013 went to Google OAuth via accounts.google.com, so somehow your machine / security settings must be balking at accounts.sketchup.com.


#13

I seem to be repeating myself here. I can’t sign in from Internet Explorer either. I set my security settings to Medium as advised in article 3000056 already. I still can’t figure out what setting may be causing this problem.


#14

Was it always like this? Or did it just start happening ?

Any recent updates ?

Have you changed AV or Firewall applications ?

In Internet Settings you might try going into “Trusted Sites” and add in *.sketchup.com


#15

If you cannot get to accounts.sketchup.com, it’s your network. Please do not get snippy with us because we’re not fixing YOUR network. I have fixed people’s networks before:

The Comcast issue was debugged by me when a school for kids on the Autism Spectrum could not get to 3dwarehouse:

Some Comcast customers were unable to connect to 3D Warehouse from the SketchUp client and the behavior was attributed to “smart packet protection” setting on the Comcast router. This “protection” was an extra layer of blocking or security for Comcast customers. It was a feature that Comcast implemented on all customers, but had since disabled on all (oops, I guess not, because I found this) customers because there were many problems with it. So, if you are unable to 3d Warehouse and still have this setting enabled on your Comcast router please disable it and try again.

You can also solve your own DNS: 3D Warehouse issues today: DNS Issue

This resulted from people telling us 3dwarehouse was broke, and so I diagnosed that it was a DNS problems for end users on the ISP, British Telecom in the UK.

And you think YOU’RE repeating yourself? Please solve your network problem and report back here and we’ll add it to the list.


#16

Dan, I’m fairly new to SketchUp, so as far as I know it’s always been like this. I haven’t updated or changed anything related to anti-virus, firewall, or other security settings since before I installed SU. I have now added *.sketchup.com to Trusted Sites, but my issue still exists.

Barry, I never said I cannot get to accounts.sketchup.com. I did not intend to get “snippy” so I apologize if my post seemed that way.

Here is what accounts.sketchup.com looks like in IE:

It looks the same whether I use “http:” or “https:”. I assume this means that I do not have a DNS/network problem to solve. I’m on Verizon in the U.S.A., not Comcast in the U.K., if that’s any help. But in case it makes any difference, I have changed my DNS servers to 8.8.8.8 and 8.8.4.4.

This is 3dwarehouse.sketchup.com in IE:

This is what I get upon clicking the “Sign In” link at the upper right corner of the page above:

Does any of this help at all? What possible reason could there be that I can load accounts.sketchup.com, but can’t get the OAuth page?


#17

Yea, so clearly from your screen shot, IE can get to accounts.sketchup.com, but when your last screen shot tries to get to it, you can’t with those params passed. That’s really weird that it wouldn’t accept that. Who’s your isp?


#18

My ISP is Verizon…


#19

I tried turning off Windows Firewall and setting my router’s firewall to “Low Security” (there doesn’t seem to be a way to turn it off), but this had no apparent effect on my issue.

I also tried to Google the problem, but most of what I found was over my head. The only possibly relevant issue that I found and understood, is that MSIE 8 has the smallest URL length limit of any of its contemporary browsers at 2048 characters, and a redirect URL exceeding this apparently will usually fail as I have described. Could this be the cause of my trouble?


#20

Hello, anybody???