Extension Manager won't stop nagging me

extensionmanager

#1

Every single time I open Sketchup Make v17.2.2555 64 bit, I get the nagging pop up window saying “you have 4 extensions waiting to be updated.”

I am at my wits end trying to get rid of that. In fact, I jumped though about a million hoops to create an account, and ended up here.

Number 1: I never installed extensions
2 I don’t use any extensions (!)
3 I don’t want any extensions (!!!)
4 and most importantly, I don’t want to be nagged every single time I open the program (!!!)

I have tried:
1 disabling the extensions
2 uninstalling the extensions (they just come back)
3 creating an account so I could repeat those same steps while signed in
4 google – found a fix online that said update/install trimble connect 2.0 from the extension warehouse. tried to do that, it said incompatible with my version of sketchup

Somebody please help?


Sketchup 2019 Feature Requests
#2

Of all the things that you said you tried, you never mentioned if you tried just updating the extensions to stop the nagging.

What are the names of those 4 extensions?

Some extensions come with SketchUp like Dynamic Components and Trimble Connect, so you’ll have at least those 2, maybe more that I can’t think of even without installing any yourself.


#3

McGordon, first off, thanks for the reply!

The main issue I have here, is that I don’t want to be nagged, because I don’t use or even want the extensions. So, I was afraid if I updated them, it would just trap me in an endless cycle of getting updates for items I never wanted in the first place.

The extensions showing in my extension manager are:

  1. Advanced camera tools (pro only)
  2. Dynamic components
  3. Photo textures
  4. Sandbox tools
  5. Trimble connect (pro only)

Since I don’t have pro, 1 and 5 are completely pointless. I have been using sketchup since it first came out on Google several years ago, and I’ve never needed plugins for my purposes. I really REALLY just wish these sorts of things weren’t forced on end users, or that there could be a built in way to turn off nagging notifications about them.

Oh, and one more odd thing. I installed this version last sometime last spring. But the first time I ever saw this notification was fairly recently, maybe about a couple of months ago tops. And every time I’ve opened the program since then – nag nag nag!


#4

Look in Window/Extension Manager to see which plugins are trying to update - probably at least Trimble Connect , Advanced Camera Tools, and Dynamic Components. Try the Manage tab, and see if they will update from there.

If not, go to Extension Warehouse in a browser, download the extensions (there are two Trimble Connect ones - I think the one you want is called Trimble Connect 2 or 2.0).

Then install them from Extension Manager/Install extension.

There were some problems in getting the updates to install automatically from the Extension Manager, maybe now fixed, which is why I suggest using a browser as a fallback.

These extensions ship with Sketchup, and automatically reinstall if you delete them. However, you can disable them, and I would recommend that if you don’t use them.

Photo Textures no longer works - Google has disabled the interface it used, IIRC.


#5

These are all Trimble extensions shipped with SketchUp. I don’t use these myself expect for Sandbox tools on rare occasions. Unfortunately SketchUp doesn’t allow you to uninstall the shipped extensions but automatically replaced them if you try to. I don’t see why, and other extensions are not given this unpredictable treatment. To get rid of the warning I think the only way is to update them.

That said I’d recommend you to look into extensions. There are plenty of useful extensions that aren’t forced onto users and that can be uninstalled if you don’t like them. It’s a pity the shipped extensions behave differently.


#6

@john_mcclenahan in my first post, I said that I tried to install Trimble connect 2.0, it said not compatible with my version of sketchup. Also, I’m not sure if you understand my issue. I don’t want to update extensions – I don’t want/need them at all! I’ve gotten along just fine for 10+ years using sketchup for my purposes as-is with no extensions. What I am trying to do, is keep the extension manager from nagging me ever again. If I update the items now, it may stop the nag temporarily, but what about the next time one of those unnecessary extensions wants to update?

@eneroth3 I appreciate that there may be plenty of useful extensions that many other people can make use of. But really I only use sketchup for one purpose, and it suits my purpose just fine. What I’m really looking for is a way to not be bothered by extension manager ever again.


#7

Update them now and then disconnect from the Internet when you use SketchUp in the future so it can’t check for updates to extensions. Or just ignore the box in the lower corner when SU starts up. It’s only present for a few seconds and it’s a tiny inconvenience in the grand scheme of things, especially since you get the software for free.


#8

Well, I don’t know if there IS a way that will stop them permanently. IF you are able to update them (and you say one of them won’t let you with your version of SU, though I don’t know why not, if it is as your profile says v17.255) you will stop the nag for those. They aren’t frequently updated, so that may be the best you can do.

I use a Mac, which may be slightly different in behaviour in this respect from Windows, but since I did update them some months ago I’ve had no more nags in v2017.


#9

You can disable extensions from the extension manager, even those you can’t uninstall. This seems to have stopped the update message for me.


#10

No offense, but telling me to ignore this problem, or disconnect from the internet every time I use the program is not helpful.


#11

You may very well be right about possibly no way to stop them, which is unfortunate, since I don’t use them or need them. My only hope is that a trimble dev might actually see this and re-think forcing this on people who don’t want it without giving them any chance to opt-out or shut off the messages at least.


#12

Also, it is inherently a flaw in the UI - to show the option to uninstall an extension, if doing so is impossible. They should disable the button, or have a dialog that says “you may not uninstall this extension” rather then let me uninstall it, but the next time I open the program it is back.

That’s sloppy design in my opinion.


#13

I have them all disabled, but I still get the message. Maybe updating is my only choice, which is unfortunate.


#14

It is annoying but the popup goes away in a few seconds.


#15

Well, I am OCD and it bothers me enough to have spent several hours researching and reading articles online, jumping through support hoops and creating an account here just to post this – looking for a solution. Suggesting that I just ignore it is not really helpful, but thanks for the reply.


#16

I understand you. I have similar problems with the animated Gif in the Instructor. I just can’t use SketchUp with the Instructor open.

Anyhow, there is one more method. SketchUp can be configured not to load any plugins at all. This also stops it from loading those shipped with SketchUp and by doing that also stops the annoying update reminder.

You can open the Ruby Console from Window > Ruby Console, paste this code snippet and press enter:

Sketchup.plugins_disabled = true

If you later want/need to enable plugins again, just replace true with false.


#17

But I didn’t suggest anything. I was supporting you being annoyed.


#18

Haha, fair enough! Thanks for the support!


#19

Hey, this looks promising! I will try that later and see if it works. Thanks!


#20

Hey this worked, thanks! By any chance, is there a quick reference for the ruby console that you can point me to? I highly doubt I’ll ever want to use plugin, but you never know, and also you never know if ticking that setting might break a future version.

When I open the ruby console again, it’s just blank. I was maybe hoping that line of code would still be there. I guess I ought to keep a log file somewhere with this info in it in case I have to change it back to troubleshoot or whatever. And knowing me – I’d forget.

Thanks again!