Exporting to DXF

dxf
export

#1

Hi there,

I was wondering if I could have some assistance with exporting to DXF or DWG. The issue I am having is that when exporting a DXF or DWG as 2D, the dimensions on the drawing become distorted and the font size is not as I set it in Sketchup, the layers are not preserved and curves are exploded. However, when exporting as DXF or DWG as 3D, the dimensions look even worse and, while the layers themselves are preserved, colour by layer for the edges is not preserved either so the document is difficult to read. I notice also that in 3D, curves are not exploded. Is there a way to export so as to preserve the colour by layer, the layers themselves, the unexploded curves and the dimensions? I will attach images of the export done in 2D and then 3D as well as the Sketchup file. Any help would be greatly appreciated!

DXF 2D Export:

DXF 3D Export:

SU File:
CNC TEST 2.skp (248.0 KB)

Let me know if you need more information in order to help!

Thanks
Thomas

EDIT: I know some of the curves on the SKP I provided are already exploded, I have welded them now but the circles on the SKP are still welded here!


#2

I have now figured out how to export, keeping the colours, the layers, and the unexploded curves but I still have the problem with the dimensions being way too big, especially since this is just three of the panels and once they are all placed in the document the zoom level will be much further out so the problem will be amplified so i need the dimensions to be zoomable! If anyone has a solution to this I would be very grateful! Even if your suggestion is for another program I can use to dimension the DXF/DWG files after exporting from Sketchup!!

Here’s my current result:


The DXF file:
CNC TEST 4.dxf (496.0 KB)
The latest Sketchup file:
CNC TEST 2.skp (260.7 KB)

Thanks
Thomas


#3

the dimensions are formatted in 11 point ~3.9 mm, in the DXF the dimension text height (variable $DIMTXT) is 0.18" ~ 4.57 mm … seems not to be very divergent.

You can obviously change the dimension text size in SU before exporting with the “Entity Info” tray or later on in the target application of course.

For checking the generated DXF/DWGs you may want use the free ‘Teigha Viewer’ f. Windows and Mac OS which ensures that import issues of the target application did not lead to a wrong impression concerning the cause of the issue.


#4

Or the also free DWG TrueView from Autodesk. (http://www.autodesk.com/products/dwg/viewers). It’s practically AutoCad with editing disabled.

Anssi


#5

Thank you, I will give Teigha Viewer a go tomorrow and also play around with changing the dimension size!

Thanks
Thomas


#6

Thank you, I had hoped to use TrueView or DesignReview but unfortunately we use Mac and Autodesk doesn’t offer a Mac version!

Thanks
Thomas


#7

Sorry, I forgot to check your OS…

Anssi


#8

No problem, I appreciate you taking the time to respond! Thank you! :slight_smile:


#9

additionally ‘TrueView’ is a behemoth whereas the small and fast ‘Teigha’ is based on the same engine the SketchUp filter is using.


#10

Thank you for all your responses, I managed to solve the problem today by changing dimension text size to a height rather than a font size!

Thanks,
Thomas


#11

@lemonmeringue Did you find a solution to the program modifiyng your dimensions when exporting ??


#12

Yeah the best way I found was to change the dimensions size in the model info window to be an actual height rather than font size by going Window > Model Info > Dimensions > Fonts and checking the “Height” box instead of “Points” and then entering a height in mm. Took a bit of playing around to find a suitable height but this worked best for me! I hope you get it to work!