Exporting to DWG/DXF from layout_ Scale incorrect

I’m having issues accurately exporting layout pages complete with viewports and drawn lines set at the same scale. When opened in Autocad the lines created in a separate scaled drawing with a matched scale measure in paper space sizing, whereas the viewport measures correctly. I’m trying to overlay hashed lines on a plan view and have everything scaled correctly in Autocad. I’ve toggled off and on just about everything in layout’s export options menu, messed with the dimension scaling in autocad, and even tried importing it to sketchup to confirm the issue. I can repeat it there, but its slightly different than in Autocad. In any event I can’t get the overlaid lines to export and open with the correct scale and measures. Thanks in advance for any help!

Hi sardine, currently we export all native LayOut entities at the paper space scale regardless if it was placed into a Scaled Drawing or not. LayOut does not support the concept of a model space with the exception of a SketchUp model view, so a Scaled Drawing is still ultimately in the paper space. Our Scaled Drawing is lost once exported and the LO geometry is scaled at the paper space scale and we assign associated dimensions a scale based on the Scaled Drawing scale.

Once exported we cannot control how to reassemble the geometry into a model space so that will fall onto the user to change the space if need be.

To do this once inside Acad, create a MView and give the MView the same scale you had for your Scaled drawing. Select the LO geometry, then type CHSPACE. Select the target viewport and the geometry will be sent to the model space.


1 Like

Thanks, Trent. I’m definitely an Autocad dummy. The bulk of my work flows through sketchup and then to Layout for basic presentation of shop drawings. I thought it would be helpful to present both PDF’s and DWG’s to my client to enable insertion of the product into the designers working drawings. I have Autocad for mac 2015. It doesn’t appear to have any recognition of the CHSPACE command.

Hmm… sorry about that, I have 2019 Acad for Mac and just found this:

You could try using the Export for SketchUp option in the LO dwg exporter and open that up in Acad. Then manually scale up the LO geometry to be 1:1.