Exporting Layout to PDF

pdf
layout
export

#1

When I export my layout file to a PDF, it looks the same in Preview, yet when it is saved, I loose all of the fonts. I believe this is something to do with PDF 1.7.

How can we save PDFs as 1.7 from Layout?

Same thing happens when printing to PDF.


#2

What does the PDF look like if you open it in Adobe Reader or Adobe Acrobat? Are the fonts correct?


#3

what do you mean?

are the fonts being ‘substituted’ or are you seeing NO text?

it’s unlikely to be a PDF v1.7 issue as all versions can handle text…

can you post a layout file that fails to export the text using the chosen font…

john


#4

They are being substituted. Im using Open sans.

Clearly not accepting the font when saving as PDF. The first image is a screenshot of Layout. The second a screenshot of the PDF.


#5

I’ll ask you again, does the font get substituted if you open the PDF in Adobe Reader or Acrobat? How about attaching the exported PDF so we can try it and see what we get when we open it?


#6

when using web fonts from Google you could try this advice from a macworld article about PDFX-3

In documents for which you have the fonts installed—but they originated from a third party—there is a simple trick that will embed the fonts automatically: just load the file using Preview, then save a copy and make sure to select the Create Generic PDFX-3 Document Quartz filter. Because one of the key requirements of PDF-X is that all fonts be embedded, doing this will give you a document that renders properly on all computers.

john


#7

Yes it does. Thank you for your help… Daniel Residence eg2.pdf (2.4 MB)


#8

Thanks John I was very hopeful, but no result… the fonts are still changing… Daniel Residence eg 3.pdf (2.4 MB)


#9

I’m getting these in eg3 file…

you have a mixture of mac and windows text, is some in from your Template?

name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
BXOWRP+OpenSans-Light                TrueType          WinAnsi          yes yes yes     17  0
DUTUCS+Arial-Black                   TrueType          MacRoman         yes yes no       9  0
KSNYIR+OpenSans-Light                TrueType          MacRoman         yes yes no      11  0
KHCLSW+ArialMT                       TrueType          MacRoman         yes yes no      10  0

#10

Some of it must be from a contractor that I was using… he was windows base.

Is this causing the confusion?


#11

It looks like that is the problem. Mac and Windows process fonts differently. You can see it in other places where padding and other spacing is different between documents.


#12

So I just go through the document and change all fonts to my MAC based ones?


#13

I think that ought to take care of it.


#14

I installed Open Sans and tried Cairo pdftocairo to ratify the fonts and it seems to work [and makes a smaller file]…

it changes the encoding, embeds the fonts subset and the unicode table, so it should be safe on any system…

name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
WAXYFQ+Arial-Black                   CID TrueType      Identity-H       yes yes yes      5  0
LPVPIO+ArialMT                       CID TrueType      Identity-H       yes yes yes      6  0
TFOIXG+OpenSans-Light                CID TrueType      Identity-H       yes yes yes      7  0
LHFWIC+OpenSans-Light                CID TrueType      Identity-H       yes yes yes     10  0

embedded.pdf (1.7 MB)

I didn’t test in Acrobat as I don’t have or want it installed, maybe @DaveR can check that out…

john


#15

It appears to work for me.


#16

Thank you John! But what does Cairo pdftocairo mean? What do I have to do? What I did yesterday didn’t work for me, so hoping this does!

Thank you so much!


#17

Brilliant Dave. Thank you for your help… I will await instructions and implement!


#18

Cairo is a 3rd party, open source graphics library…

it’s not trivial to install unless you use Xcode and have Homebrew already…

but simple to run from Terminal.app once installed…

pdftocairo -pdf /Users/johns_iMac/Downloads/Daniel\ Residence\ eg2.pdf /tmp/embedded.pdf

I was curious as to what it would do to create a compliant file, and then have a look at doing the same with more accessible tools…

john


#19

Thank you John. I have tried to install this, but I’m afraid its all a little beyond me… I really have no idea what I’m doing…


#20

easiest way is…

instal Xcode from the app store…

then go to the Homebrew site and follow instructions for installing it…

then use Brew install Ciaro in Terminal and it will load all of the required files…

may take a while…

EDITL here’s one GUIDE

john