Exporting Layout File to PDF Problems-Help PLS!

So i made a complete set of building plans in layout. Im done and ready to send them out for bid. When I got the viewport to the point I wanted I locked it so it would not change even if i changed the sketchup model.

When I try to export the model to PDF it updates all the view ports/pages to the current model and it causes it to not be correct due to the fact the locked viewports are what I want to display. There are just too many layers and differences that I need to show to have made each one an entirely new scene.

I want to export the layout to PDF with what I see and not what layout automatically makes it adjust to the current model. Please tell me I can make it happen someway without litterally redoing 17 pages of completed project pages

Are you still using SU/LO2018?

You could unlink the SketchUp file from the original. Then LayOut won’t look at the modified SU file but only the embedded one.

Yes. Im still using the 2018 version. I believe Ive tried that. But the embedded model appears to also be the same issue.

I guess you could open the embedded file and undo the changes that you made before opening the LO file the last time. Alternatively you could explode the viewports which would disconnect them entirely from the SketchUp model.

Going forward, if you find you need to make changes to the SketchUp file that is already associated with a LayOut file and you don’t want the LayOut file to reflect those changes, you could either unlink the file in LayOut or you could use Save as and give the SketchUp file a new name before you start making changes.

Any other ideas. Every time i export it or unlock the viewports it changes. Is there anyway to save as a file that just displays what I see?

As I wrote, explode the viewports. And probably you’ll need to undo the changes in the SketchUp file.

You have disabled Auto Render of the viewports, right?

How do i disable auto render of the viewports without unlocking them? Im asking this question because going back and undoing everything I’ve done to the model/scenes isnt an option anymore. It just simply wont let it happen.

Do you have one viewport linked to that model that won’t change when it is unlocked? You could unlock it and while it is selected untick the Auto Render box. It should remain unticked for the other viewports.

This is what i got when i do that on a scene/page that doesnt change when i unlock it

Auto Render is turned off in the SketchUp Model panel which should be in the tray on the right. Probably need to scroll up in the tray. If you don’t see it, select it from the Window menu so it does show up there.

In pre-2020 versions of LayOut the camera view and style changes you make to viewports are not retained when the viewport is re-rendered. That is why you should create scenes in SketchUp that look exactly like you want them to look in LayOut, and make your viewports refer to them.

Version 2020 changes that, viewport overrides are now saved.

1 Like

If I send you the file can you save it as a layout 2020 file, Save it to PDF, and send it back to me? I Understand I’d have to get the new version of layout/sketchup to edit it any further but If i can just get this dang pdf to look like the layout does that would save me 40 hrs of rework

Also One more question to ask. If I just bite the bullet and get the $299 2020 subscription can i use layout 2020 to defeat this problem? If so im doing it yesterday and it would be worth the savings. I might also add i undid auto render so when I unlock the view ports it doesnt change. But it still changes on the export

I Used screen grabs from doing the plans as a slide show in layout. Worked ok. Little pixelated but legible. Im going to see if the print shop can take them and make them clearer. In the meantime if you guys have an idea on if the above will work id love to hear it

If you have Dropbox go to the web and look at the file history for the old version of the SketchUp model. Restore it and relink it to the layout file.
In the future if you want to keep a snapshot in time save a copy of both layout and SketchUp file as a set somewhere. I keep a folder called “Iterations” for this purpose.

I bought sketchup 2020 to try and save this endeavor and use the viewport override feature. How to I make my locked viewports export

Can anyone explain to me how the viewport override feature works?

With the viewport selected, go through the SketchUp Model panel. You can change the style, visible tags and other settings.

I keep seeing that in layout 2020 there is a view port over ride feature to where you can lock the viewport after youve made changes in layout and it will export the way you see it and not the way the model wants to automatically render it

You can lock the viewport by right clicking on it and choosing Lock.

If you make changes to the model later but don’t want those reflected in your LO document, unlink the .skp file from the LayOut file in Document Setup>References.