Exporting to PDF objects disappearing in Viewports

I just upgraded to 2019 and I am tying to export a LayOut file to PDF. The problem I am having is on some of my pages the viewports are dropping out objects from the viewport. I can watch it happening as I am exporting. I did not have this problem with LayOut 2018. Does anyone have any ideas what is going on or how I can fix this?


Windows or Mac?

How are you getting the SketchUp file into LayOut to create the viewports?

I inserted the file into LayOut and just copied pages to create new pages. Windows

When you installed SketchUp and LayOut, did you right click on the downloaded installer file and select run as administrator to install it?

probably but not sure. And this problem is only happening to the viewports on 2 pages of a 30 page PDF

Either way, it would be a good idea to go back and install SketchUp again using Run as administrator to make sure.

Is it possible there’s an issue with the content in those viewports? Are the viewports all from the same model? Can you share the LO file so we can try it and see if we see the same results?

Thanks - reinstalling would be an ordeal. I am in Japan and my company is in the USA - they have all the licencing information. Yes, all the same model. I am checking the model to see if there is something different with the model components in these viewports

Reinstalling shouldn’t be an ordeal at all. You don’t need to uninstall first and you won’t lose license info or extensions or anything. You’ll just run the installer again and when the option appears, select Repair.

Components from the 3D Warehouse?

OK - I will try this at the end of the day and components I have made

not sure if this is helpful but I locked the viewports then everything in the viewports disappeared on export

I personally after about 10 pages will create a new layout file.

And what if you don’t lock the viewports?

What if you only export the pages that drop the viewports as a PDF?

if I don’t lock the viewport - just certain elements of the model disappear

Thanks but I have never had problems with the number of pages in my LayOut files and I have made some really big LayOut files

try to make a copy of the skp and insert the copy, see if you get the same results

Thanks for all the help. This seemed to have fixed the problem. The SketchUp file was a an overall group. I exploded the group, saved the file and reloaded it into LayOut and now no problems with exporting a PDF from LayOut. Not sure why this worked but it did. Thanks for your suggestions

That smells of bad components. I worked with a fellow awhile back who was experiencing something similar. When we found the offending component and removed it, the issue went away.

thanks for the suggestions - I exploded the SketchUp file and reloaded it and that seemed to have fixed the problem - thanks for your help

Exploded it? That sounds a bit excessive. But I guess, if it works…

I have seen groups that were offenders, usually created on a Mac, though. Something to do with zoom extends, as if they were hiding something(not noticable by bounding box) very far from the origin.

Once exploded (and regrouped directly), the symptoms were gone.

Never got to reproduce, though.