Exporting animation turns out as a black video


#1

Help. I tried several times to export my animation. When finished the export the mp4 file is all black. It has 50 scenes. Is there a limit in number of scenes? It is also very slow.
I do not know what to do. I have to finish it for my work as a garden designer.


#2

What SketchUp version ?
(Your forum profile has not answered the 3 computer questions.)

Did you choose any particular options from the Options dialog ?
(Button at bottom of the Export dialog.)
Try choosing a smaller size.


#3

if Windows try updating the graphics driver first.

If SU v2016 (and older) disable “Window > Preferences > OpenGL > Use Hardware Acceleration” before the video export and re-enable afterwards.


#4

I updated my profile. SU 2017, Windows 10 Nvidia Geforce GT 740M.

I tried several options from the option dialog.Even the smallest “custom” did not work out fine. I tried again without shadows and than it succeeded. It took about 2 hours to finish.


#5

SU v2017 has higher demands to the graphics driver (OpenGL v3.0) because of e.g. an advanced transparency system… with an up-to-date graphics driver version 378.66 from 14.02.2017 disabling shadows shouldn’t be necessary… besides of a bug of SU.

Ensure to have this latest driver version installed (e.g. by “Windows Search: dxdiag > Display”) or download and install from here (W10 x64).


#6

Thank you both for your help. But untill now no result. Let me tell you what I have done. I downloaded the latest driver.
Exporting the animation however did not work well. It stopped after 37%. After that I copied the model into a new file. Again I exported the animation. This time it stopped at 36%. For the third time I tried but again it stopped at 37%. I got the message that Su does not work anymore. So I had to stop. I do not know what I am doing wrong.


#7

try if updating to the brand-new SU 2017 Maintenance release 2 fixes this issue already, simply install over your existing program installation (everything will be kept).


#8

how much working memory does your system have?

you may want check with the Windows Task Manager (“Windows Search: taskmgr”) if working memory is going to the end during the runtime of the animation export. And check via the Windows Event Viewer (“Windows Search: eventvwr”) what has happend to SU excatly (see “Windows > Logs > Application”).


#9

I updated SU 2017 as in your reply. This also did not work. I have Ram 6,0 GB working memory.

I also looked at the log. I see a lot of things I do not understand, so I will ask someone to look at it. Now I made a new animation with less scenes. That helped.

Thank you so much for helping so far.


#10

which is not very much, check w/ someone computer savvy if uprgading RAM of the notebook is possible (if botoom has a lid it’s very likely).


#11

All the entourage components you use, especially plants, seem to be fully 3D. They will make your model unnecessarily complex. As you were able to export if you turned shadows off, this might be the problem.

Anssi


#12

Thant’s correct. It worked without shadows.
Thank you.


#13

for shadows you may want use much lighter 2D components in combination with the component option “Always face Camera”: