Animation Export Issue

animation
#1

I am trying to export an animation but it keeps on crashing around 50%.

Computer Memory: 16384 MB
Graphics Card: Intel® HD Graphics P4600/P4700
Sketchup File Size: 232 MB

Is there anyone with a more powerful machine who would be willing to export the animation for me and send back? Please let me know.

#2

Can you add some info about the animation you’re trying to export? Resolution? Format? Length…maybe that will help diagnose as well.

1 Like
#3

Sketchup%20Model%20Info

to give you an idea of the model

Also, I am trying to export animation at 1080dpi, 3 second transitions with almost 50 scenes. I realize this is a great task for the machine to render, but I figured it is possible somehow.

Thanks for your help

#4

In the scenes tab you could limit animation to 10 scenes ( include or exclude from animation) , then do the next 10 etc and stitch them together.

2 Likes
#5

Also, you may consider posting the model to File share site and post link here if not sensitive as I’m sure someone can try exporting the animation to confirm if it’s a model or machine related issue.

1 Like
#6

Good suggestion! I will have to give it a try

#7

do you know of any easy file sharing sites for upload?

#8

Dropbox or WeTransfer best. Google Drive’s good too.

#9

Can you provide an email to send it through WeTransfer

#10

PM’d you for transfer.

#11

Ok, so several issues to consider:

First, when you showed the Model Info/Statistics screenshot, it showed only 16,000+ edges but if you check ‘Nested’ it’s becomes 15,300,000+ edges. Really big model for most machines.

Second, purge unused and fix problems in the model as that will reduce model size down to 196 mb…not a big change but every little bit helps.

Third, do you need edges and shadows to show? That takes more time to process each scene as it switches from one to the other…especially when the high-poly vegetation layers turn on. I’d recommend updating the style that you’re using in the scenes to not show edges or profiles if not needed.

Fourth, you can try exporting smaller size ie 720p instead of 1080p) and / or reducing frames per second. I tried it with 24 frames/second and it told me it was going to export 3,458 frames to make the animation…that takes awhile, again, dependent on your machine.

Lastly, I got about a third of the way before quitting SU as it was taking too long to export. From the part of the video that did export…it looks like there’s no motion…just layers turning on. If that’s the case, I’d just export the scenes as 2D image files and composite them in another program vs making SketchUp duplicate the scenes so many times to make it appear to animate as the scene’s layers build up.

#12

Thanks for taking the time to check it out! Because of the visual effects, I’d like to keep edges on, but I will definitely purge unused layers and fix problems in order to lighten the model a bit.

Yes, the first 10 or so scenes are just layers turning on, one after the other, to show how the design comes together. These would definitely be able to be exported as images rather than rendered as scenes of the animation. I will try out your suggestions and let you know how things go.

Thanks again for the tips!

#13

No Problem, also try @whiterabbitdesigncompany 's suggestion of exporting scenes in batches and then composite together in video program. You can do this by saving 2-4 copies of your model and deleting groups of scenes so each animation export is dealing with fewer scenes, therefore fewer images during each round of exports.

#14

I’d suggested “unchecking - include in animation” for (scenes 11 -30 - they will get a bracket around them) so only 1 to 10 will render in the animation output, then recheck 1 - 10 uncheck 11-20 and so on.

I wouldn’t delete them and will save the file copies.

1 Like
#15

Ah yes. Of course. Don’t let me confuse things. Multi-tasking lesson learned!

1 Like