Exporting a useable dxf


#1

I may be ignorant, but after multiple searches, I discovered that the dimensional errors I was getting in dxf files I was trying to export were caused by a relatively un documented need to select the parallel view in the camera choices, before trying to export the drawing.


#2

Sorry you struggled to figure this out - perhaps the documentation doesn’t make it clear. It seems like an issue of misplaced expectations, though.

The most important thing to understand is that SketchUp is a 3D modeling program, not 2D. Although you can draw planar 2D objects, they are actually placed and oriented in 3D space. When you view them in SketchUp, you can orbit around your 2D objects just like full 3D ones. If you look at a plane from an angle, you get foreshortening just as you would if you held a piece of paper at a slant while you look at it. If the current camera uses perspective, you will also get converging parallels, decreasing size with distance, and the other visual phenomena that make up perspective - again, just as you would get if you viewed an object in the real world.

The misplaced expectations are thinking that if your model is 2D embedded in 3D that the export 2D function will somehow figure this out and magically reorient the view to be flat-on before the export. Or that it will assume because your view is flat to one of the cardinal planes that you meant to turn off perspective during the export.

But that’s not what SketchUp does; it exports a verbatim image of what is currently displayed on the viewport. The fact that some export formats are vector or other geometric format doesn’t change the statement above: SketchUp generates a 2D vector image instead of a raster one, but it is still in effect a screenshot. It still shows the geometry exactly as you see it on the viewport, including any distortion due to the current camera projection. Since the intent was to output an image corresponding to the current view, this is actually what many people want.

So, if you are trying to get a traditional drawing view of your model, you need to set it up so that the SketchUp screen shows that traditional view - top, side, whatever. And you must choose parallel projection, because that is what was assumed in those traditional (intentionally unrealistic) drawing views.


#3

thanks for your reply. I just came back to the forum and saw it.
I did find the small print that says to use the parallel projection rather than the perspective and that did solve my problem, and now seeing your comprehensive answer confirms it. I am on board with you as far as the 3d issues compared to the old 2d.
I will make a point to check in to the forum more regularly in the future. Thanks again.

Greg


#4

You can have a look ath these settings in your preferences: