Exported Collada from blender shows edge gaps in sketchup


I have looked for similar questions extensively but I cannot find anyone with this issue.

I modeled a sofa in blender, exported to collada, as usual, but this time the model shows edge gaps in sketchup, no matter what I do.

I tried to solidify, scale, remesh, merge by distance, decimation and whatever I could think of.
No matter what, the model shows edge gaps in sketchup.

When I try to open the skp file generated by the collada file, the model opens perfectly in blender, no gaps whatsovever.

The only thing I noticed is that the gaps occur on the intersection of the stiches with the surface.

Anyone knows what is going on??

Thanks in advance!
TEST.skp (12.4 MB)

Looks to me as if you’re seeing back face color bleeding through at some of the edges. You can amplify it by turning off edges and setting the back face color to something bright. Here I’ve set the back face color to red.

It’s just an OpenGL artifact.

By the way, please correct your forum profile. It says you are using SketchUp Free. Your screenshot shows you are using SketchUp 2023 Pro.

Thanks for the reply DaveR.

I tried to do as you,ve sugested, painting the inner faces, it worked!

Any idea on how to avoid this kind of artifacts, before exporting to collada? I think I am missing something.

“By the way, please correct your forum profile. It says you are using SketchUp Free. Your screenshot shows you are using SketchUp 2023 Pro.”

I am using my work laptop, the company is paying for the license. This is my personal profile. Since I don´t have sketchup, it seems a bit weird to put it in my profile. Should I change it?

Instead of painting the back faces, just change the back face color to something dark.

As far as the artifact there’s not much you can do. It’s a limitation of OpenGL. There’d be nothing to change for the Collada export.

One thing you might consider is reducing the complexity of the piping geometry. There’s no need to have so much fine detail.

It should reflect the actual version you are using even if your employer is providing the subscription. Incorrect information doesn’t help us or you.

1 Like

DaveR, changing the back color does not work for me, but painting the back faces does the trick.

I am probably doing something wrong.

…and by God!, I can´t find anywhere here where I can change my profile info. Am I this dumb?

Probably so…

What did you change the back color to?

click on the B in the green circle at the top right of the forum window. Click on the person icon, then Preferences, and then Profile. Remember to scroll down after making the corrections and save the changes.

It did not work because back faces were painted, must be a bug.

Now, the question remains for me, as far as I understand.
If a client receives this file and opens it on his interior design session in sketchup, it will have the gaps, right?
Depending on what he does to his skp file, some ■■■■ will probably happen with this model.
How to avoid that?
Is collada the best format to export models from blender to skp?

Not a bug. Remove the material from the back faces so the back face color will show.

It shouldn’t have gaps but depending on their graphics card and how they are using it, the back face color may bleed through.

I don’t know if it’s the best but it’ll work. It wouldn’t hurt to simplfy it, though. If it’s to be used as entourage in a SketchUp project, it’s too large and too complex. The fine detail will be lost and the object will be more of a liability than an asset.

I know it was not a bug, if its painted, its painted, it was a joke.

So if I understand you well, what is causing the bleeding is the complexity of the pipeing, correct?

I dont think it is that complex, still working on it though, it was a test to see how it goes.


As I mentioned previously, the piping is way more detailed than it needs to be. No one looking at the entire couch in a room will ever be able to see that detail. That detail is wasted and is just contributing to file bloat.

Consider that your couch model won’t be the only object added to a project. You can find lots of examples of people using heavy components like your couch coming to this forum looking for help because their computers can no longer handle their SketchUp files because they are bloated with heavy components like you couch.

Even some low level cleanup like reducing the overly large texture file and cleaning up some unneeded edges and faces reduced the file size by more than 32%.
Screenshot - 9_23_2023 , 4_29_27 PM
Simplifying the piping and elminating the unneed geometry on the bottom would reduce the file size even more.

well I like triangles, but that’s a lot of them :slight_smile: you might want to smoothen a bit your couch in blender, removing half the geometry can help a lot and won’t be visible, especially with that “fuzzy” material (it’s like a dotted camo, it breaks the shapes and makes them look a bit non flat)

also, you could, in blender, reduce complexity : basically your couch is 4 parts : seat, back rest, right and left arm rest.
all the contact areas between these parts can just disappear. it’s complex geometry for places you’ll never see. also, the underside. same reason.

here is a car I used in a project, in the background. you can see I deleted anything not visible from the outside. if the things you model are to be used in context (not as the centre of attention), you can treat them as decor. like props in a movie set.

edit : well dave edited his message to say the same, lower polygon count and complexity, remove useless invisible stuff, it’ll help :slight_smile:

Excellent tips you just gave. I havent considered that the unseen parts can be uterly simplified.

I agree that the polygon count could be reduced, no point arguing that.

But… if you see furniture modeling in my country, you will find pieces of furniture with more than a million polygons, simple stuff, couches and the like.

As a king in the 3rd world, I remain having the lowest polygon count in the history of high poly count.

All the help is greatly appreciated!

Or totally removed.

It doesn’t matter what country you’re in and just because others are making morbidly obese components doesn’t mean you should.

Sorry. I didn’t know you are the king. Maybe you could consider setting a much better example for your subjects.

often, when a designer models a piece of furniture, they will make it as a standalone. the file suffices itself, you make a couch, a beautiful couch, and you can observe it.

but the scope in witch the 3d will be used is actually important.
you wouldn’t do a 500K polygon door handle to put on a door in the background of a 4000x2000px image would you ?
well a designer paid to model door handles for the door handle company will anyway. And people will use it and wonder why their model is so slow.

Plus, exporting from one software to another often means triangles. any face will be converted to triangles, adding extra geometry.

Such hi def models are better suited in rendering tools or using proxies, at least on SU. the more elements you plan on having in your project, the more strain you’ll put on your machine with hi def models.

There’s a plugin called universal importer, it can import more than 50 formats, but the best feature imo is the polygon count reduction without losing the shape of the model.

Try to work with quads and make a clean topology, in one piece, to avoid those artifacts and also to have smooth surfaces.

And for SketchUp (but not only), create a low poly model, which you can easily convert into a high poly model.


I managed to reduce the poly count to 19.000 in blender.

I downloaded Subd but I keep getting “unable to decrese subdivision. Select one previously subdvided group”

Not sure what is happening…

Is the model you tried to reduce the number of polygons in Blender created with quads? If it is not, first remesh it as quads and low poly.

Just because you downloaded SUbD, it doesn’t mean you can directly do what you want. First you have to learn how to use it and also have the mesh correctly created.

“… it doesn’t mean you can directly do what you want.”

Now , that´s a problem, I really want to do what I want.

BFW keeps pressing all the buttons frenetically with no success…

Good for you, but first learn!

This is what small children usually do when they discover something they like.

1 Like