Collada export of a Sketchup model with materials and layers



I am trying to import a Sketchup model (.skp file) into Blender and then later on into Unity.

First, I did the default Collada export, but upon importing the .dae file into Blender, I got nothing.

I, then, followed the instructions on this webpage: but the result was just an empty Blender scene…

Something that might be useful to know is that in my first attempt to use Collada export, there was a folder craeted (during the export process) with 3 materials in it. It basically means my model uses some material (brick texture, metal surface, etc…) which might be the reason for the failure of export/import processes.

Has anyone run into such a problem before? Is there a work around for this kind of work that deals with multi-layer multi-material 3D models craeted in SketchUp?


p.s. I would be happy to send my file over to someone who believes they could analyze it and see perhaps what the problem might be…


hjmiri; Some FYI for you;
There is a obj object exporter plugin for SU 2014 make version of SU that supports exports, look under TIG’s tools. MeshLab can be used for many different file conversion.
SU 2014 had a change in its API form 1.8 to 2.0 and some plugins had to be modified to be compatible so any you use make sure it is available in the extension ware house if using.
Couple thoughts after reading your post.


Please post your skp model

#4 (1.4 MB)


Thank you for this info. I have uploaded my model ( and I would appreciate your further help…


Scale problem back with 8" elbow so deleted post above.:((



  1. Sorry for delay almost concurrent with your model post started having issues with my PC but have some comments that may help you:
  2. Before exporting purge your model using the windows=> model info=> statistics=> and purge all plus purge materials, components using the respective browsers;
  3. At my first attempt to import to Blender the 8" elbow imported larger then building size. You probably need to scale the definition;
  4. Your use of layers is incorrect for the SU architecture in that it uses layers to control geometry visibility ( Not isolation) vs. some programs use layers for geometry isolation. ref Basically this means any entity shown on the layers panel should be a group or component;
  5. Blender as well as many other programs have selectable options for export use. When you export the dae (Collada) for example there is a selection box with option for your use on the right side of the panel you should use. This may have contributed to some of you initial issues
    I hope to have better input for you later to day(;


Thanks very much mac7595

By ‘elbow’ are you referring to the ‘female’ character that is part of the SU scene?

I will follow your advice on this, and see how I can improve the model.

I would very much appreciate your further help…



Sorry for my delay mac7595 and thank you for your reply…
I will follow your advice on this, and see how I can improve the model.
I will be in touch…


Attached FYI is test file and materials exported from SU to Collada ( dae). The problem with the scale was caused by some thing I did to your test model so hope all is well now ;
When you export it is normal to have the material files and the dae model. Blender does not paint faces to start;
Blender units are set to 1 m. If enabled then blender adjust its self to the unit system and I think that was the initial cause of may size issue;
I made some changes to the layers so it will look different to you. I am using the new version 2.7 and noted while reading this version it has some presets you can use to help with unity=> probably add on. There is also add for import and export of obj format;
I used the following SU export options: Edges, triangulate, hidden, comp. Hierarchies , Texture maps (120.0 KB)


Missed skp file
test.skp (575.1 KB)