Importing Sketchup Models into Blender


#1

Hello,

Has anyone ever imported a Sketchup model (.skp or .skb files) into Blender or Unity?

I would like to determine whether to use Sketchup at all for creating 3D models, because at some point I will need to create textures and apply them to the models, and then import them into the Unity rendering engine for use in Virtual Reality simulations and applications…

Thanks,


#2

Blender can open many 3D file types, including Collada (.dae) that can be exported from SketchUp.

Anssi


#3

Thanks Anssi . .

I exported a .skp file (just a simple 3D model of a house) as a Collada file, and then launched Blender and tried to import it.

It seemed promising, as Blender had the .dae file extension as the default mode of import, but the result is just an empty Blender scene…

Have you done this before yourself, so perhaps you can tell if I am missing something here?


#4

Hey there, I made a video about this (specifically for the Oculus Rift): http://youtu.be/rAef7ZJ7ViI


#5

hjmiri- I’m the IrisVR tech guy. What kind of VR are you doing? Are you using an Oculus Rift?


#6

Hi Shane,

Thank you for this.

Your video is amazing and very informative, but still too advanced for me!

The SketchUp model is just given to me, so I have to work with whatever is passed on to me. I have attached an example for your consideration…

When I get a SketchUp model, I do File -> Export -> 3D Model and then I choose Collada format as export type, and finally save the results.

The results are always saved as one .dae file and one folder with the textures that have been applied to the SketchUp model by the graphics artist.

  • The 1st thing I don’t understand is why I would need Blender in this process?

  • The 2nd thing I cannot figure out is how to open this Collada file in Unity, because when I copy the results (i.e. the .dae file and the folder containing the textures) into my Assets folder, the Collada file doesn’t appear in the Project view. I can only see the folder containing the textures. At this point, I am thinking “So, maybe that’s why I need Blender!”. So, I go back to the results of my Collada export from SketchUp, and try to import it all into Blender. I launch Blender and do File -> Import -> Collada (Defaul) (.dae) and then I realise that the model doesn’t have the textures applied. How do I use the folder of textures to get the whole thing imported?

Even though my problems may be basic, I would very much appreciate your helping me understand the underlying concepts…

Thanks in advance,

3_storeys_flat_roof_textured.skp (523.7 KB)


#7

Hi Nate, I have sent you an email…


#8

1)When you export as . dae there are options you may need to select on the right side of the screen;
2) Once you have open in Blender then you need you materilas , the properties screen on the right side has info for that;
3) If you are new to Blender you should read some of the basic getting started tutorials; http://cgcookie.com/blender/cgc-courses/blender-basics-introduction-for-beginners/?utm_source=mailchimp&utm_medium=email&utm_content=basics&utm_campaign=welcome-to-blendercookie&mc_cid=3c5a3f96e4&mc_eid=3ef4c70245


#9

This is the same issue you previously posted about. I had spent some time correcting what I thought were problems with previous model so will let that info stand.
G day


#10

Thanks mac7595. I will go through this info again. Cheers,


#11

I re-look at the model you have attached and is is much better than before. However, if you double click on one ofr your components then select some primitive geometry, such as a line, the entity info should report that item is on layer 0 but your does not show that. That was one of the correction I made in my previous post. I can not say this will casue you down stream problems so it is your decision on action ,but Su expects that.
BTW I did a search on UNITY and turned up this link which addresses some of the question about its import export and export and gives some guidance on same: http://docs.unity3d.com/Manual/HOWTO-importObject.html


#12

I found a solution for this a few weeks ago in fact. Getting from SU to blender is the tricky part - Blender to Unity is a straight up export.

1 - From SketchUp export to FBX. (pro only feature)
2 - Download FBX converter from Autodesk - free! - [FBX Converter][1]
[1]: http://usa.autodesk.com/adsk/servlet/pc/item?siteID=123112&id=22694909
3 - Convert FBX to Wavefront OBJ
4 - Import in Blender
5 - Party!


#13

Also, another simple solution is to try to import your Collada file into Unity instead of putting it into the hierarchy yourself: http://answers.unity3d.com/questions/43174/how-do-i-import-3d-objects-in-collada-dae-files-in.html


#14

There is a TIG obj exporter for SU and in the manual I mentioned above states unity can import obj so all the conversion may not be required.??


#15

I found TIG obj exporter / native SU obj to be not very Blender friendly. At least for anytime I tried to use it. The workaround makes perfectly compiled, and audited obj files.

If jumping directly from sketchup to Unity I suppose DAE may work.


#16

Thanks I think it will only import FBX , obj, Max or Blend. further reading seems to indicate TIG’splugin uses some of the native pro obf exporter so for free user it will not work.


#17

Can this file extension (dae) be exported form sketchup 5? If not, is it downloadable?


#18

here’s how to install the plugin directly imports SketchUp files (.skp) in blender: http://apptecnicofree.blogspot.com/2015/06/blender-instalar-addon-import-sketchup.html