Export to KMZ file

I need to get a file into Google Earth. I geo-located my file as instructed in the videos I’ve found, and exported my SKP to a KMZ file. Google Earth only has an option to load a KML file, but does allow you to select the KMZ file. At first nothing would appear, but now, with Google Pro, I get an error message that says it can’t open the file. I save the file asMyFile.KMZ, but says it’s looking for MyFile.kmz/models/untitled.dae. Anyone know what the “models/untitled.dae” means?

I just made a test file which I exported from SU2021 as KMZ and then opened in Google Earth Pro. It worked fine for me. Can you share the .skp file so we can try exporting it?

What were the steps you followed for geo-locating the file?

I go to File > Geo Location > Add Location, select my location and region, and import it.

I then place a test mass on the site and File > Export > 3D Model and it is exported to the KMZ file.

I then open Google Earth, go to File > Open and open the file. Google Earth goes to the correct location, but I get the error message below…

My test SKP file is attached. Thank you for your help!
Test KMZ Export.skp (1.3 MB)


Just downloaded your file and exported the KMZ. This is what I get in Google Earth Pro.

Can you open the KMZ in GE-P?
Test KMZ Export.kmz (2.3 KB)

Are you still using Windows 7 as your profile indicates?

I can’t open the KMZ file in GE-P, I get the error message. Is there a setting in GE-P I need to look at?

And this is on Windows 10

It seems Google Earth Pro on your machine may be the culprit and not the export from SketchUp then.

Nothing that I know of. I’ve never made any settings to be able to open these. Out of curiosity, what do the settings under the General tab look like in Tools>Options? Which version of Google Earth Pro are you using? Help>About Google Earth.

Perhaps you could update your profile?

I downloaded GE-P yesterday, version, and am new to it. Previously I was just using the online version to play around… Maybe I need to pay somebody something for Pro?

I have I just downloaded the latest installer but get a failed to install message when I try to run it. I’ll reboot my machine and see if it will install after that.

I don’t think you should need to do that.

Redownloaded the installer and now have the current version of GE-P installed. It also opened the KMZ file with no trouble.

Try closing Google Earth if it is open, find the downloaded installer, right click on it and choose Run as adminsitrator. If you get the option choose to repair it.

I uninstalled GE-P and then re-installed it. The problem persists, and it has something to do with the DAE file that is associated with the KMZ file I am exporting from SketchUp.

When you export your file from SU to KMZ, do you set any options?

No. I didn’t select either of the options.


You said you get the same import problem with the file I exported and yet I was able to open it that file just fine. That would indicate the problem is on the Google Earth side not on the SketchUp side.

I agree. I’ll keep hunting for a solution

DaveR - Would it possible for you to share the test KMZ file you created and successfully uploaded to GE-P?

DaveR already posted it in the 4th post…

My mistake. The upload in the 4th post was mine, and DaveR said it worked fine for him. I was thinking he had created a new one from scratch to test I still can not get my KMZ file to work on either my laptop or desktop, and with either Google Earth or Google Earth Pro.

No! The KMZ that I posted was one I generated from your .skp file. I showed that the one I exported worked fine in GE-P and shared it. Here is another one I just made quickly.
Example KMZ.kmz (3.2 KB)

I just wonder if GE Pro has all the required permissions or if some security software is blocking something. Do other KMZ files work?
Are you loading the KMZ file from your computer or some cloud service or from a folder that is synced with the cloud?

1 Like

@Anssi would you try the KMZ file(s) I shared and see if it opens for you?

That last one isn’t too far from Finland… Minnesota. :slight_smile:

Joining the party a bit late here. The only kmzs shared in this topic (@DaveR’s I think) open fine in GE-P (desktop app) on my Mac. I am not 100% certain, but I don’t think that online GE will open kmz’s any longer. This change came about when Google ceased creating 3D content for GE using SketchUp.

FWIW, a kmz is a renamed zip file that when created by SketchUp has the following contents (using Dave’s first kmz as an example):

Archive:  Test KMZ Export.kmz
  Length      Date    Time    Name
---------  ---------- -----   ----
     1352  08-04-2021 03:45   doc.kml
     7753  08-04-2021 03:45   models/untitled.dae
---------                     -------
     9105                     2 files

The doc.kml file gives the geolocation information for the model and specifies where in the zip to look for the geometric data. In this case it is in the models subfolder as models/untitled.dae, and is a Collada file built from the SketchUp model contents. It would also be possible to have kml (Keyhole Markup Language) geometry contents, but SketchUp does not use that format.

I’m wondering if there is a permissions issue based on how you are running either SketchUp or GE-P. Are you launching either of them via right-click “Run as Administrator” (as opposed to running installer that way but launching the app itself normally)?

Another remote possibility: do you have a zip utility installed that might be interfering with GE-P’s attempt to unpack the kmz?

1 Like