Export to .dae freezes at 99%

dae
export
collada

#1

Hi, I am trying to export a 75mb Sketchup 2013 into a .dae format. When the files was smaller (70mbps < ) I was able to do this no problem, but now i am having trouble. It pretty much instantly goes to 99% and then stays there forever (I left computer on for 4 hours and nothing changed). Any advice?

Thank you


Dealing with large project
#2

I have seen cases where i had to wait longer than 4 hours to export a file.
Also, the percentage doesn’t mean much, because I also have experienced them hanging at 99%

as it is a large file to upload, I won’t ask you to upload it for us to inspect.
but maybe you can try to export parts of it?

it may be some part of the model really dragging you down.
try omitting those suspicious parts first to see what is causing it.

perhaps you can assemble different dae files in different software?


#3

If you right-click on the task bar and select Start Task Manager, you can see how much memory is being consumed while you are running the export. Click on the performance tab and check the numbers shown:

If the Physical Memory is near 100%, it means that the computer is now using the hard drive in addition to the memory (which is slower on the order of several magnitudes). If this is the case, it will take much much longer than you would expect. However, my experience has been that it will finish. Eventually. I suggest you start it running before you go to bed and check it when you awaken.


#5

The import options has a validate selectable, make sure you are not using import. I have had issue with it doing the 99% thing with the validate option selected on that one ,;under the red arrow of the task manager above is a resource monitor that will give you much more insight what is going one internally. Item to look for when you have that open is wait chain analysis, probably help you to read the help file on that;
Check the export options are selected properly read help file on that. Those options you will see in right corner on export screen.


#6

as a reminder…

the Progress Bar only indicates the time SU takes to read in the data contained in a file…

once read, it stays at 99 while it generates the needed geometry, layers, etc…

If you have selected to validate, this is done after the generation into memory is complete…

It’s impossible to calculate how long that will take, so the message just waits…

once complete, the ‘Statics’ are displayed…

then SU moves everything from memory into the model…

it should at least change to let us know it’s moved on to the next stage, but it doesn’t yet…

john


#7

I guess that’s why it always hangs at 99%.

Strange what it shows though. (this can be confusing to some people as it is unexpected)


#8

As a strange workaround that we don’t fully understand, geolocate your model by adding a manual location, then export to .kmz and if that works, unzip the .kmz and you should have model.dae inside.


#9

Let me know if this worked for you. Thanks.


#10

Hey thanks for all of your suggestions. I ended up leaving my computer on overnight and I got the file to export.

Barry, I will try your suggestion the next time I need to export it. Thanks for suggesting it!

You guys are awesome :smile:


#11

Barry, does the method you explain keep the texture mapping in the .dae file within the folder?
Mine is getting stuck at 50%… not 99… but, I like the idea of the .kmz workaround if it works. However, does the .kmz export allow for very heavy, high poly models?