Export STL has blank screen under Windows 10


#1

Hi, I recently switched to Windows 10 and now when I try to Export an STL the popup is a blank screen and unable to export. I tried to reinstall with no success. Any advice…Thanks!


#2

Also, I can’t find the STL Importer (*stl) file anywhere on my computer after I installed SketcUp STL from the extension warehouse.


#3

I assume you mean the ‘official’ STL toolset installed from the EWH ?
The STL Exporter appears as a File menu item.
The STL Importer presents as a file-type under the native Import dialog’s drop-down list…

I assume you mean the STL Exporter’s own dialog is blank.
Since it’s a web-dialog, please check your Internet Explorer installation is up to date and that your Internet Options are set to allow Javascript, and not be overly restrictive etc.
Irrespective of your day-to-day web-browser, SketchUp always uses IE on PCs when creating all such dialogs, but IE needs to be up to date and not have overly restrictive security settings etc…

Can you run any other tools which use web-dialogs ?


#4

Yes, I am using the official SketchUp STL from the EWH. It appears in the SU File menu, when I try to export an STL the dialog shows the title “STL Export Options”, min/max/close buttons, and the rest of the dialog below is blank.

I tried lowering the security of the internet options and the Exporter’s dialog box is still blank. I recently updated Windows 8.1 to Windows 10 and through that process updated IE. On Windows 8.1 I never had this issue with SketchUp STL.

The extensions (tools) that have installed all work however, I am not sure how to check if they use web-dialogs.

I will keep trying to adjust the Internet settings…


#5

Windows 10 has Microsoft Edge and Internet Explorer. I wonder if Edge is interferring with Explorer on allowing SketchUp STL to work properly since it is a web-dialog?


#6

I have tried it on Win10 and it works for me…

Check that IE’s Internet Options are set to allow Javascript to run etc…

I had SketchUp v8’s properties reset to run in compatibility mode fro Win7 and as administrator…
Obviously ALL versions of SketchUp are not tailored to suit Win10 - it was invented long after these versions were created - so you need to make some experiments with settings to see how to make earlier versions like v8 work…
Seems to work just fine for me, although I would not use it for serious work anyway…


#7

That’s good to hear STL Export works on W10.

The IE Interent Options are enabled to allow scripting of Java applets. I am not sure what other settings I could change.

What would you recommend for serious work?


#8

[quote=“TIG, post:3, topic:15399”] set to allow Javascript,
[/quote]

Java and Javascript are two totally different languages…
make sure Javascript is enabled…

try using one of the SU’s web dialogs, i.e. Extension Warehouse, 3D Warehouse, Add Location, etc…
do they function fully?
john


#9

I have shape bender from the EWH and it works.


#10

And my scripting is enabled.


#11

I reinstalled SU and now it works, I am guessing part of the file was connected to a program I had recently unistalled. Thanks for the help!


#12

Doh! Should have spotted that !
When you install SketchUp you need to do it “as administrator” [not just a user-who-has-admin-powers], otherwise some things - like web-dialogs using IE - can become screwy !!


#13

@TMS1 As an FYI and shameless plug here, you can side step exporting as an STL from within SketchUp when you upload your file to 3D Warehouse and use our new Printables feature! 3D Warehouse now allows you to export as an STL and it even cleans up your model for 3D printing in the background for you!

Thanks,
AlexB