When I download Sketchup Pro to a new computer It does not allow exporting my files as .stl for printing

I have a valid Sketchup Pro 2017 license. I downloaded Sketchup to a new computer. It does contain in the export menu an option to export my files as .stl for printing. I have a client waiting for a model but I am having to work off of my old machine. Can anyone help?

Have you added the .stl exporter extension from the Extension Warehouse? You would need to do that with SU2017 as .stl export wasn’t included as a native export type until later.

Oh my, no I had no idea. Thank you for that, I will try. That is a great help!

Actually it did come loaded with the software I have on my laptop. Looks like SimLab is not free. But will try the trial version and if it works will buy it. Thanks again for your help.

Why don’t you use the free SketchUp STL?

It doesn’t show up under my files menu in the software I downloaded to my new machine. I have been using it in my old machine

Ho did you install it? After installing it, did you quit out of SketchUp and restart? Did you install SketchUp correctly in the first place by right clicking on the downloaded installer and choosing Run as administrator?

So the whole story is, .stl export resides on my old machine and I have used it for years. I purchased a new machine, downloaded sketchup pro 2017 with my valid license, applied my SA#. Sketchup comes up, but export to .stl is no longer an option in my files menu. I reloaded Sketchup 2017 Pro but I get the same thing.

Not sure I remember the exact procedure. I downloaded the .exe file from sketchup i think and ran the .exe after it downloaded. I still have the downloaded file

As I told you, in order to get the .stl export option in SketchUp 2017 you have to install the exporter extension. SketchUp 2017 does not have a native .stl export feature. It doesn’t matter how many times you reload SketchUp 2017, it won’t have it until you install the extension.

The correct installation procedure is to right click on the installer and choose Run as administrator. At this point you should do it and choose Repair when the option is presented. You still won’t be able to export .stl files until after you install the .stl exporter extension though.

Dave I hate to keep bothering you, but I did what you said, right clicked on the download file from sketchup, ran as administrator and selected repair. Sketchup loads just fine. There is no menu option to export as .stl. When I go to the extension warehouse to download an stl exporter, the only options are from Simlabs. They say free, but in actuality it is just a free trial. Also, I tried their software. It insists on exporting the entire sketchup file rather than just a component or group. So in the slicer, up comes all of the components in the model. So how can I get my old exporter back?

And you shouldn’t expect to see one for the reason I already described.

Evidently you are not seeing the free one I’ve linked to.

If you’ve been exporting .stl files from SketchUp 2017 on your other computer and you never bough the SimLab exporter, you must have installed the SketchUp STL exporter instead. To get that capability on your current computer you have to install it on that computer.

I don’t mean to be disrespectful. If you read my entire reply I loaded sketchup, then went to extension warehouse to Install an stl exporter plug in. The only ones I find are from simlabs. They say free but they mean free trial. All of the options appear to point to the same plug in. I installed it and tried it out. It will not export a single component or group it insists on exporting the entire sketchup file. Even the little man. It’s not what I had in my previous version. Also, not to argue, but, I did not install an extension in my previous version, it resided as a menu option under the files menu. I’d been using it since I learned about 3D printing in a sketchup boot camp some 3 years ago. No other suggestions?

Ahh. That was it, I have it now. We had a little communication issue I believe. Thank you for your patience and all the time you took

1 Like

What was “it”?

I was loading the wrong extension, I didn’t see that sketchup had its own extension. The sketchup extension works much better.