STL add on does not work right for 2015


#1

It exports the items not highlighted, not the items highlighted. Guess I will just stick with 2014.


#2

That sounds odd - I cannot reproduce that. The code should be neutral to whether it’s SU2014 or SU2015…

All though - there are some different versions of STL import/export. Which one are you talking about? (And what OS are you using? And if you use windows, 32bit or 64bit?)


#3

64 Bit, Windows. Using the SketchUp version

It looks like it only happens when I start with a 2014 version drawing. If I draw the item in 2015, it works okay.

Starting with a drawing produced in 2014 version, then editing it in 2015, the export function actually exports the items not highlighted.


#4

Hm… I tried that as well. Still not able to reproduce.
Any chance you can do a video capture? Maybe we’re missing some critical step to reproduce this.


#5

Bonjour Tom Tom,
Nouveau sur ce forum, mais utilisateur régulier du plugin “sketchup-stl par SketchUp Team”, je me permets d’intervenir ici pour confirmer le non fonctionnement de ce dernier dans SU Make 2015.
Cet outil fonctionne parfaitement dans SUM2013 et SUM2014, et ce, même pour de très petits modèles.
En effet, je l’utilise avec succès pour convertir des fichiers .skp en fichiers .stl me permettant de produire du Gcode (depuis Slic3r ou Repetier-Host), et de commander une imprimante 3d. A condition que le modèle soit "un groupe solide dont toutes les faces sont orientées), je convertis facilement même de très petits modèles (exemple ; un objet s’inscrivant dans un volume de 25 x 20 x 23mm comportant 7664 facettes au format .stl).
Je confirme que ce plugin ne fonctionne pas du tout dans SketchUp Make 2015 que je viens d’installer (en réalité c’est la version d’essai pro dont il me reste 22 jours d’utilisation).
J’ai réalisé un test à partir d’un volume tout simple de 60 x 40 x 30mm produit d’une part dans la version 2014, et d’autre part dans la version 2015 pour laquelle Slic3r m’adresse un message d’erreur lors de la demande “Export Gcode”.
Je joins des captures d’écran pour illustrer mon propos.
Je reste à votre disposition pour d’éventuels tests complémentaires vous permettant d’identifier le problème.

Test_SUM2014_Captures.pdf (174.7 KB) Test_SUM2015_Captures.pdf (84.6 KB)


#6

Can you try this for me:

  1. Create a test model - simple box - in SU2014. Export to STL
  2. Save the SKP
  3. Open the same SKP in SU2015, export to STL
  4. Check if the SU2015 is failing like you described.
  5. Upload the two STL files here so I can inspect their content.

#7

J’ai essayé, mais sans succès, de copier mon modèle créé dans SU 2014, puis de le coller dans SU 2015.
Je viens donc d’essayer ce que vous me demander, et cela fonctionne, à savoir :
1°) J’ouvre dans SU 2015 mon fichier SKP créé dans SU 2014, et sans même l’éclater pour recréer un groupe dans SU 2015, j’obtiens un fichier .stl exploitable par Slic3r.
2°) J’ouvre dans SU 2015 mon fichier SKP créé dans SU 2014, je l’éclate pour recréer un groupe dans SU 2015, et j’obtiens également un fichier .stl exploitable par Slic3r.
3°) J’importe, sans aucune différence, les trois fichiers .stl aussi bien dans SU 2014 que dans SU 2015.
Pièces jointes :
Test_SUM2014.skp
Test_SUM2015.skp
Test_SUM2014.stl
Test_SUM2014_Import2015.stl
En souhaitant que cela vous soit utile pour identifier le problème, je reste à votre disposition pour d’éventuels autres renseignements.
Test_SUM2014.stl (1.7 KB) Test_SUM2015.skp (20.8 KB) Test_SUM2014.stl (1.7 KB) Test_SUM2014.stl (1.7 KB)


#8

Wait, so all those files worked fine?


#9

Thomas, I haven’t sent you anything. The last several communications are not from me.

Kent Hurley


#10

Yes, I’m aware of that - I was replying to bharralure49.
I see you replied via email. If you are replying to email notification then please beware that they are directly connected to the forum thread you started and replies are posted back there.


#11

I can’t reproduce either of these problems. For me, .stl files exported from SU v14 and v15 are identical.

@nvrr49 can you provide a sample model and precise steps to reproduce this? Or as Thom asked maybe a video of the problem.

@bharralure49 I have downloaded your files, installed Slic3r but still can not recreate the error.

The latest STL extension version is 2.1.4 - make sure it is up-to-date for all versions of SketchUp you have installed.


#12

Bonjour Jim,
Tout d’abord, je confirme avoir installé la version “sketchup-stl-2.1.4.rbz”.
D’autre part j’ai identifié le problème : lors de la génération du fichier au format stl, je n’ai pas coché la case “Export selected geometry only”. Vu la multitude de fois que j’ai pu utiliser cette fonction, je suis confus et impardonnable… et vous présente toutes mes excuses pour cette perte de temps inutile.