Possible export bug

Hello,

Starting a few days ago, whenever I try to export my file to .stl it exports an old version of the file. I’ve tried saving it as a different file and that doesn’t work. The file in sketchup shows my changes and edits. The exported file doesn’t. It’s very frustrating. I am not allowed to select versions like if I were to download the file regularly - this is an “export” issue.

I’ve reset, closed browser, etc.

This wasn’t an issue until recently. I really need to get this file to my 3D printer. Can somebody please advise me if this is a bug or not?

Thank you!

I wondered if the file needed to be saved, but I did a test, and exporting STL gives you exactly what you see, including the latest changes.

What are your steps for getting the STL from the browser, to Chrome OS, and then to your printer? Do you have access to any other computers, so that you can at least get the printing done?

I had mentioned in my previous post that I have tried saving things as a different file. This has worked with no issue up until next week. I save and export to .stl. My changes aren’t showing up. The file size is exactly the same every time. i’ve tried:

Computer reset
System upgrade
Clear cache
Reinstall Chrome
Save as a new file
Log in/log out
etc etc etc.

This is my primary computer so unfortunately I don’t have another one to try. I have even tried saving my regular sketchup file under a new name (without exporting), exiting the current one, and opening the new one, and it has reverted. I don’t understand what is happening.

Can you include the steps that you do inside the SketchUp web app? For me, I would click the three clines menu in the upper left, choose Export, STL, and would immediately get a good STL file. No steps involve saving or saving to a new file.

Do you have a way to download the SketchUp file, and post the SKP and the STL you get somewhere, or attached them in your reply? I can’t immediately think of a way that it can fail, but there could be something unique about your model.

What happens if you start a new model, and export a simple box as STL?

Those are the steps I follow to export an stl.

I can try and make a box and edit it and see if that works. I wouldn’t mind sending the model directly to somebody but I can’t post it publicly because it’s for work.

I’ve rebuilt geometry to make flat planes and I’ve moved certain points. The geometry reappears and the poitns have moved back whether I save a new skp and reopen it or if I export an stl.

Then you shouldn’t be using SketchUp Free for this.

I have a license for the full version of sketchup at work - I can send you the license information as proof. I brought this file home to print on my 3D printer at home so I can demonstrate it 3D printed. I’m just trying to remove stray geometry before printing it. The files are not updating before printing. I’d be happy to continue to provide you extra information about a potential bug in your web free version.

Did you see my direct message, for you to reply to? If you look at your avatar in the upper right of the forum page you will see blue dots for when someone has replied publicly, and green dots for when there is a private message for you. Click on the avatar to get to the message.