Export Sketchup to DWG - sizes come out wrong?


#1

Hey,

I’ve been learning to use Sketchup to create basic 2D drawings so I can get things laser cut. The shop requires AutoCAD file formats so I’ve drawn something in Sketchup to scale (everything measures millimetre perfect) but when I export to DWG and open this file in AutoCAD the measurements aren’t the same.

Sketchup measures a circle at say 10mm (both top to bottom, and left to right, perfect), but AutoCAD measures the same thing at 9.68mm (left to right) and 9.24mm (top to bottom).

Does anyone know what causes this? I’ve tried looking everywhere but can’t see any reason for this.

Thanks


#2

I am guessing (without seeing your actual file) that you might be experiencing an issue with “circles as segments”.

Below are two circles with different numbers of segments, but both drawn with the same radius. You can see how the dimensions to the outside of the circles are different:

You can increase the number of segments in your arcs/circles, OR you can use the 3d export to export your DWG/DXF file (exporting 3D creates different info than the 2D export).


#3

I’m guessing your not exporting a 3d top view in parallel projection…

if you do, you get true circles that will be defined by radius…

john


#4

Also note that when you export from SketchUp as a 2D graphic, the export is a verbatim image including the representation of circles by polygons. If you export as a 3D model, circles will be exported as true circles.

Which is basically what @john_drivenupthewall said.


#5

Untitled.skp (2.3 MB)
I’ve tried 2D and 3D exports, none show exactly 10mm circles. I’ve attached the file here if anyone can view this?


#6

if you turn up model units precision to 0.00 you’ll see you have a variety of sizes…

john


#7

I took a look, and none of your circles are 10mm. I pulled them together, and you can see they are all different sizes:

I would recommend bumping the accuracy of your units from one MM to a few extra decimal places (Model Window, Units). then, when you draw a circle, increase the number of segments (from 12) and input a radius of 5mm when you draw the circles.

@john_drivenupthewall - So fast! so animated!


#8

Wow massive thanks guys, they say a picture is a 1000 words but a GIF?!

OK, I’ve bumped up the accuracy and can now see they’re not perfect.

I’ve deleted them and have created new circles, I still get the same weird thing with the 2D export where the left/right up/down measurements are different, but the 3D export seems to be 10.00mm perfect in AutoCAD this way. The only thing that confuses me with the 3D export though is that everything seems to have 2 lines to it, like they’re overlapping. I’m worried this will cause problems with printing? See attached,


#9

are you using Top View >> Parallel Projection for exporting?


#10

In the Export Options (which is a button on the export dialog) untick Faces.


#11

As Box said, the other “lines” are the edges of the polyface that got exported alongside your circle. Polyfaces, like faces in SketchUp, have edges consisting of straight segments.

Anssi


#12

Thanks guys, I’ve now exported without the faces and it looks tons better.