2D scale exporting

I’ve read every other thread on this I could find but it still does not work properly. The scale is off by a fair bit and way too much work to correct in another program before milling. I’m exporting 2D and I don’t even have the option to turn off 1:1. I’m also viewing the file flat from above when I go to export. The export options scale numbers aren’t even the correct dimensions of the entire drawing being exported and it doesn’t let me set them individually. Locks them together in a particular aspect ratio. however the aspect isn’t what’s wrong, it’s the overall scale of the file that’s off.

3D export seems to work but it doesn’t give me the lines and if I turn on all the options, I get double stacked lines that aren’t connected. 2D gives me the correct model but the wrong scale.

I’ve tested this across multiple year versions of google sketchup as well. They all do the same thing and it’s extremely frustrating. Help is HUGELY appreciated. Thank you :frowning:

Can you share the SKP file so we can see what you’ve got? If you can’t share it publicly, send it to me in a private message by clicking on my name and then the Message button.

Are you setting the camera to Parallel Projection and the appropriate standard view before exporting?

Awesome I had no idea this thing could share files.Scale issue file exporting.skp (281.5 KB)

There’s another issue too. Any way I export it, It doesn’t seem to want to give me the vector drawings of just the lines. All the file sizes are well over 1mb when they should be a few kb. The smallest file is when I export just the lines with the 3D exporter but that one doesn’t seem to want to work right.

Yes the camera is paralleled. I have the orthographic view toolbar on so I know it’s exact.

The file is 150mm x 150mm yet this is what the exporter is showing.

If I try changing it, the aspect sticks and is all wrong. But the actual exported file is the correct aspect.

See? It was worth getting out of bed this morning after all.

The first thing I see if that you do not have the camera set to Parallel Projection. This would explain why you can’t get the scale set correctly.

I’m not sure what you are getting at with the vector lines but I would send the file to LayOut, render as vector and export the CAD file from there.

Check out this DXF. Does it work for you? It was exporting from SU.
Scale issue file exporting.dxf (368.1 KB)

Try changing the Camera to ‘Parallel Projection’ and view from above by clicking on the ‘Top’ house icon; then export the dwg.Scale issue file exporting.dwg (177.0 KB)

Yes the camera is paralleled. I have the orthographic view toolbar on so I know it’s exact.

The file you sent looks good to me. I’ve sent it to the miller to see if it works out right. Should hear back quickly. I’m going to try layout right now too.

There. Corroboration. Camera to Parallel Projection.

It was not set to Parallel Projection in the file you uploaded.

Here’s a DXF from LayOut.
fancy bracket.dxf (640.6 KB)

Are these the wrong tools to parallel the camera?


Also, I tried importing or copy/pasting into layout. No luck at all…I haven’t used layout

Those set the standard views but you need to go to the Camera menu to select Parallel Projection.

Before you go to LayOut, create a scene showing the model as you want it to show in LayOut. In this case that’s with the camera set to Parallel Projection and the Top standard view. Save the file and then in the File menu, click on Send to LayOut. (Don’t copy and paste from SketchUp to LayOut.) When LO opens, choose the desired paper size. Then the model will show on the page. With the viewport selected, set the scale in the SketchUp Model panel and choose Vector for the rendering type at the bottom of the panel.

1 Like

This is what the layout export looks like in Corel Draw which is what I use to confirm. Those cross lines are the vectors I need but not where they are…

And here is the actual problem. All the little lines and not actual shapes.

I don’t see either of those things when I open the DXF files in the CAD program.

When I parallel and try to export the scale is still off.

Why have you unticked the Full Scale box?

Yes that one you sent me I’m still waiting on response from the miller it seems to look right.

This is my view when I ‘send to layout’. Something is different than yours. It seems to just send an image…

Right now I’m trying to figure out how you got that DXF file

If I leave it checked it’s wrong. If I uncheck and try to fix it’s wrong. I don’t know how to make it right.

I changed the style to Hidden Line (one of the Default styles) in SketchUp to get rid of the colored background. No need for that. You skipped the step of changing the rendering to Vector.

You also skipped my instruction to create a scene in SketchUp and you’ve modified the Last saved SketchUp view in LayOut. Go back and read my instructions, above.