Export model as PNG and all should have the same dimension

Hello,

I have drawn some wood joints and I would like to make an overview now. So far I have proceeded as follows:

  1. Create different models in SkechtUp (all have the same height).
  2. Create screenshot
  3. Photoshop adapted the document to 1200px*1200px

The problem: I now have all documents or models at 1200*1200 pixels, but the heights are quite different. See:

How can I export each model as PNG (1200*1200 pixels) and get the same height of the model on all images?

The easiest thing would be to put them all in a single file so they are easily aligned. Assign a different layer for each joint. Create a scene for each one using the same camera position. Or insert them into LayOut and set the viewports so they all have the same scale.

Creating separate files for each of those isn’t very efficient anyhow.

Please complete your profile with SketchUp version and license type.

3 Likes

That’s interesting. So your recommendation is to pack all connections into a single skechtup file? Why?

I explained why in my previous reply.

Please correct your profile. There is no SketchUp 2018 Make.

1 Like

Yes it is Pro 2018 :wink:

@DaveR Ok, I’ve implemented that now and it works really well. YouTube tutorials and your keywords were a great help. Thanks a lot for your contribution.

Now that I’m unsure: how do I export each connection/scene with the desired dimensions (1200*1200 pixel) as a PNG file?

Easiest thing would be to use LayOut but failing that, you can make the SU model viewport square (use Eneroth Viewport Resizer) and then set the image export to 1200 x 1200 in the Export Options.

1 Like

Thanks @DaveR

If I choose option 2, then I never get the exact number of pixels. There is an aspect ratio somewhere.
L0ymHxaBxN
Any idea?

What steps would I have to go with layout?

You neglected to make the model viewport square first.

In LayOut, set the paper size to something square, insert the SketchUp model and set up a scene on each page showing the joint you want. Set their scales all the same. Export an image set and in the process, set the image size to 1200 x 1200.

1 Like

this ia what dave means by ‘adjust the viewport’…

it’s also best to use multiples of 2 pixels…

the ratio is more important than matching sizes. so 1400x1400 is as good as 1200x1200…

john

Just curious, why are you using 3d software to document very simple 2d artwork?

@gsharp
Because I also need 3D views :slight_smile:

@john_drivenupthewall
I installed the extension, but if I shrink my window nothing happens. At least not as with you :slight_smile: The setting I now so notice is the following:

@DaveR
I’ve got a few scenes set up and it’s going really well. My question now is: is SU limited with the scenes? Because I really need a lot of connections (100-150) and accordingly a lot of scenes. Is that possible or what should I pay attention to?

Have you run into a limit yet?

If I were doing that many I would make scenes of similar pieces–maybe four or six joints per scene. Then use LayOut as I described above. You can crop the viewports in LO to show only one joint and if you want, you could have 3D views and a 2D views on the same page.

1 Like

you installed Enroth’s which is PC only,

I’m on a mac, so I wrote my own to make the gif of adjusting the viewport manually…

sorry for any confusion…

john

Hello @DaveR

I’m working on your recommendation, and it’s working out fine. I’ve done this before:

  1. Import new connection
  2. Align new connection (axes and contour lines)
  3. Create layer and assign connection to a layer
  4. Create scene

That works pretty well. But I have a problem now. As soon as I insert a new connection, the existing scenes have the new connection in the scene. So I have to hide the new connection and update the scene.

That’s no problem with 5 connections, but once I have 20 connections and I update the 20 scene connections every time, it becomes cumbersome. Here is a short recording: https://recordit.co/A0tTl7PQsQ

First, you shouldn’t be using Hide to control entity visibility in scenes. You should be using layers for that.

You could import your new connection and give it a layer assignment for a layer that isn’t visible in your scenes. If you don’t already have such a layer, created one with Auto-Invisible Layer which is expressly designed to make newly created layers invisible in existing scenes.

This is one of those rare cases in which it’s useful to make a layer other than Layer 0 the active one. Just be sure to set it back to Layer 0 before you go on after importing the file.

1 Like

I really want to thank you. That helps me a lot! Especially the plugin is a big help.

But I don’t quite understand what you mean by that.

What do the steps look like?

Sorry please - I’m probably asking stupid questions. :grimacing:

Start here: https://help.sketchup.com/en/sketchup/controlling-visibility-layers