Export in VRML format in metric system, not Imperial System

Hello All,
When I tried to export in VRML *.wrl file, the default unit is in inches. I couldn’t find anyway to make it export in centimeters or meters. (Windows => Preferences => templates does not work)
Is there anyway to modify the the export preferences?

Thanks.

What units are you using to model in SketchUp? Usually exporters use the same units as you do when modelling. Otherwise the unit might be built into the export file format. You can change the current modelling unit any time in the Window menu>Model Info>Units dialog. Template settings only affect new models you start.

1 Like

Thank you for the reply. I drew the cube in meters with 5 x 5 x 5 meter, but when export to wrl, it becomes inches. Then I reset the template to inches with new model, but same issue exist.

I also tested with model units set to both inches and meters and the output .wrl files are identical (coordinates expressed as inch values.)

Moving to Technical Problems category as this is a bug.

from: “The Virtual Reality Modeling Language Specification”, Version 2.0, August 4, 1996

4.3.3 Standard Units

VRML provides no capability to define units of measure. All linear distances are assumed to be in
meters and all angles are in radians. Time units are specified in seconds. Colors are specified in the RGB (Red-Green-Blue) color space and are restricted to the 0.0 to 1.0 range.