Bug / Feature Request - No way to apply new regional unit format to existing files

This is for the free web version of Sketchup.


I started creating a new model, and the default app template was set to Architectural - Feet & Inches.

After a while, I didn’t want this setting anymore, so I changed it to Fractional - Inches. However, this setting change did not carry over to my existing file. I even tried duplicating the file to see if it would apply the new global app settings to it, and it doesn’t. Every time I take a measurement with the model that originally had Architectural - Feet & Inches as the setting, it keeps giving me the measurement in feet and inches, even though the current app setting is set to Fractional - Inches.

Steps to Reproduce

  1. Create a new file/model
  2. Open the App Menu in the upper left, and open App Settings
  3. Verify that the default value under Regional → Default Template is Architectural - Feet & Inches
  4. Create a basic object such as a rectangle, and make it larger than a foot such that the measurements show both feet and inches
  5. Open the App Menu and go to App Settings again, and now change the Default Template to Fractional - Inches
  6. Use the Tape Measure tool and measure the object you just created

Possibly related but may be irrelevant - the Model Info settings are also set to 1/2" format with a precision of 1/64".

Expected Result

The object measurements should be in inches and fractional inches only

Actual Result

The object still measures in feet and inches, as if the change to the Default Template didn’t apply

Other Thoughts

IMO, it’s odd for this setting to appear in the global file menu in the first place because there are other units settings in the model info panel which let you set precision and even switch to decimal format right there on the fly. It’s strange having to look in two different places for units and measurements settings. Perhaps all units and measurements settings could be consolidated down into one context panel, and then the regional formatting could apply on a per file basis instead of globally, with no way to apply it to existing files.

It would be nice to be able to choose fractional units in Model Info. Until the feature is added, try this. Start a new session with units set to Fractional. Then import your model into it. Explode the top component level. Will that get you what you need?

1 Like

That worked. Thank you DaveR!

1 Like

Good deal.

As I wrote, I think being able to switch to Fractional units is a good feature request and I’d like to see it implemented. Still, planning ahead is a good idea. If Fractioanl units are the appropriate units for your modeling projects, having those selected as your default when starting a new project is best. I’m guessing you’re modeling woodworking projects for your home shop with SketchUp so starting out in the units you’ll use normally makes sense.

1 Like