Export as dxf issues and lightburn

when i open the options pane in sketchup to export as a dxf file, it shows that my object size is 30 inches by 17 inches. But the actual size of the part is 6 inches by roughly 7 inches. Why is SU showing the wrong dims?

second, if anyone has lightburn, when i import the dxf file, its super small and scaling does not work because it imports it with very odd numbers of 0.439 by 0.29 inches.


fins.skp (276.1 KB)

Share the SketchUp file with us so we can see your set up.

fins.skp (276.1 KB)
here it is:) work area is set for inches on this one since it is a basic shape to be laser cut

First thing I see when I open your file is that the Camera is set to Perspective. You need to set it to Parallel Projection and the standard Top view. Also use Zoom Extents to get the model to fill the model space as much as possible. It’ll also help if you adjust the model window to fit more closely with the model. Try that and see what you get.

Why aren’t you using LO?

1 Like

i had it set to parallel projection, i switched it back before saving so i wouldnt forget when moving in 3d.

Using zoom extents, and top view with projection, it still imports extremely small and SU shows very large dims in the options

Probably the import units.

This is what I see.

odd, mine shows the 30 x 17 still. i even tried all the release version in the drop down haha

You’re missing something. Go back through the instructions I gave you and make sure you’ve done everything.

What happens when you import this .dxf file?
Fin.dxf (132.1 KB)

i just closed the program, reopened it, and followed everything exactly, and still same issue.

using your file in lightburn, its imports wrong dimensions as well.

As I wrote, it must be the wrong import units set in Lightburn. I don’t use that so I can’t guide you on that end.

1 Like

as for SU, it still gives very large dims in the export options. It seems like its grabbing the camera view rather than the actual size of the object. IE, the width is 30ish which would match from the left toolbox to the right pane window. SO its grabbing camera space rather than just the object dims.

Did you resize the SketchUp window like I told you to do?

Those dimensions on the left are for the entire model window. That has nothing to do with the dimensions of the geometry.

1 Like

yes, ctrl+shift+E to zoom extents.
for now, ill grab the base and height of the bounding box and use that in my laser software.

You seem to be ignoring the point about resizing the model window, though. That will impact those dimensions on the left side.

i resized the window

zoom extents is resizing the model window? or do you mean to even shrink the window space more somehow?


Drag the SketchUp window to make the window closer to the shap of the part.

1 Like

how do i do that. never needed to do this step until now haha

Click on and drag the end of the entire SketchUp window.