Everything I draw is warped

Everything I draw ends up a little bit warped. Here’s a simple example. How do I get my Sketchup World normal again?

Are you viewing it in perspective?

Try Camera/Parallel projection (in desktop versions of SU).

But unless you are trying to draw only in 2d, learn to use the Perspective view.

Attach the model so we can see what you are working with. It looks like you have changed the axis of the model or the axis of the component.

I see what you mean, I started in flat so that I could easily draw the floor plan and then I pulled up the walls and continued drawing 3D items but did not change the view. Does that matter?

Thank you for wanting to look at it!

It’s not letting me upload it though.

Could it be related to my changing the field of view?

Do you get a message about the file being too large to upload or is it maybe the new user limitation?

From what little we can see in your screenshot, it appears that you’ve drawn some of the edges off axis. The field of view won’t really matter in this case.

Maybe the latter because I resaved it and took out everything apart from the simple model in the screenshot. I don’t get it cause I simply place a rectangle as normal so I expect it to be straight in all directions (hope I’m making sense ;-))

I’m sure there’s a simple explanation that will be clear when we can see your model. Try again to upload the .skp file here or upload it to Drop Box and share the link.

Actually, checking the size it’s almost as big as the original!
231 MB.
It’s holding on to information I thought I deleted (I guess).

Ah… Go to Window>Model Info>Statistics and click on Purge Unused. Then save and upload that. if it’s small enough. Or just use the Drop Box method.

SketchUp keeps components and materials even if you delete them from the model space. It’s a useful thing in many cases but it also means that simply deleting them doesn’t get rid of them.

Yes that worked!

Here is the file

Cristina Sketchup resaved for warping issue.skp (10.6 MB)

It’s as Box suggested. You’re axes were moved and things are off axis. Here’s a top view of your model as you uploaded it.

The objects in your model are at the crossing of the guidelines. Notice the guides aren’t parallel to the red axis.

Right click on an axis line and you’ll see Reset is available. This means the axes are not in their default location. Click on Reset.

After Reset the axes are in their default location although your model and the guides still aren’t aligned. This implies you’ve probably moved the axes more than once.

It would be best if you keep your model close to the origin and probably easier to work if you leave the model axes in their default location.

Here I’ve moved those objects closer to the origin. The ends of the countertop are not square to the front edge. I don’t know if that is intentional or not.

Edit: I see now why your groups were so far from the origin and why the model is still quite large for no more than was showing. You have a lot of content with hidden tags. Here the tags are turned on.

If you don’t need all of those copies of the floor plans I would recommend getting rid of the ones you don’t need. Were the floor plans imported or something you modeled in SketchUp?

1 Like

Wauw, thank you so much!

The original drawing on the left was imported and all the other ones are mine. I draw it once and then copy/move them to show the home owner various possibilities. By now I’ve learned about tags ;-D but it is helpful to look at them this way. But indeed it is better to remove them once a decision has been made (and having made an export of the options). I’m going to try your fix now.

Thanks!

1 Like

Perfect! You (all) made my day. Thank you so much.

1 Like