Evergreen -- slow select tool

I have a twist on the perpetual slow select tool in Sketchup 17.2.2555. A left click shows the 5-7 second delay before an object is selected. However, a right click selects the object immediately and shows the context menu. This lets the object be selected right away, but creates another issue. I can work on a single object with a right click then either select a menu action or hit Escape and then work with that object. However selecting multiple objects with either a marquee select, shift select or ctrl select still has the long, maddening delay.

The fact that I can select the object immediately with a right-click seems to show the selection can be made with existing settings, updates and drivers, and something else is causing this issue. I have tried all the fixes proposed by others in the past – Windows updates, graphics drivers, etc. – to no avail. I can’t use the free Sketchup web-based version because I have extensions I need to use. I would be super grateful for any assistance or insights. Thx!

Can you share a sample SKP file that exhibits this problem. Trying the select thing with the same model you are using but on a different computer could help to sort out the problem.

What are the extensions you need to use? What other extensions have you got installed?

reboot until the select tool works…it may take multiple reboots

Dave, thx for the quick response. It happens with every file, even with a blank file with just the standard human figure. I’ll make a small skp and attach it. The extension I use is TF Rubies, an extension for timber frame construction.

Sample.skp (139.6 KB)

This is what I see with your file.

Generally, slow select was identified a long time ago as being related to integrated GPUs and bad graphics drivers. You indicate you checked graphics drivers. Did you check with Intel directly or did you let Windows tell you if the drivers are up to date?

Long shot but when you installed SketchUp, did you right click on the installer and choose Run as administrator?

Have you tried what @mics_54 suggested?

I havn’t had the select tool issue in several months with this same system. I don’t leave SU open while putting the laptop in sleep mode.
My system updates as it’s supposed to.
For quite some time I had issues once a month and rebooting fixed it but that hasn’t happened for a while now.

@mics_54: When it happened to you, could you right-click and select immediately as I’m able to do even with the slow left-click select??

geoffk99 yes I think I recall that being the case.
Are you saying rebooting isn’t working?

I’ve rebooted 4 times, no change.

All my apps are installed as Admin, my account is an Admin user member.

That’s not the same as right clicking on the installer and selecting Run as administrator.

1 Like

Sorry, I left out an “and” meant to say: All my apps are installed as Admin AND my account is an Admin user member. I have repaired the install and rebooted a couple more times. No joy. It was a problem for more than a year, so I muddled through with right-click. Then it “fixed” itself about 6 months ago and worked great for about 4-5 months. Now it’s a problem again. Super frustrating… Puzzling why right-click works immediately while left click has the delay.

Have you tried a different mouse? Is your mouse wireless?

SketchUp 2017 hasn’t changed in years. The problem is elsewhere on your machine. For most users who have reported this sort of issue, the problem has been one of two things. The most common problem has been related to integrated graphics cards and their drivers.

Following on from @DaveR, when it fixed itself 6months ago there was most likely a win 10 update that installed a good graphic driver to your system, then 4-5 months later the win 10 update installed a different driver that didn’t work properly.
The trick is to find the most recent driver directly from the Intel site not Windows and install that. If that doesn’t work you need to go back to the time when it was working and find that driver.
Always always check your system after win updates and if something is wrong, roll back the driver.

1 Like

people never seem to get the difference.

I down loaded a driver manager from INTEL and ran it then installed the correct updated driver …again…from INTEL and never looked back. Are you using a desktop PC or a laptop? What Brand?

It’s an HP 9470m laptop with 16GB RAM and the Intel HD Graphics 4000. The version of the graphics driver has not changed for many months.

I went to the HP site to get an idea of what your unit was. By todays standards it my be time to upgrade. Many of the updates HP offers are from the '14 to '16 period. The graphics was released in 2012. With the advancements in the software and its demands …………… upgrade? SU has changed drastically in its requirements since your unit was built. Also possibly your unit is starting to fail.

I have to say, I feel a bit shamed for having a laptop that doesn’t measure up to your standards. I’m sure that wasn’t your intent, but that’s how it came across. This configuration has more than enough capacity to drive SketchUp, as it has done so since I installed SketchUp.

I’m not demanding 8K graphics at 60 fps from this hardware, just seeking assistance with a software program that has worked for quite some time that is exhibiting a well-known issue and advice from someone who might have insight from how they resolved the issue.

I appreciate the assistance and support of the community, but I don’t appreciate feeling shamed over something that’s clearly not the problem in this scenario. I have explained in pretty good detail that the application actually works perfectly fine except for the slow left-click select tool. It’s not the hardware, it was some software update, so let’s stick to the specific issue and not go down rabbit holes.