[error unexpected file format]

This is better than literally starting from scratch. :smiling_face_with_tear:
Thank you so so so much, Sir! :slightly_smiling_face:

Hello, I got the same problem. Could someone try to help me please? I’m going to upload the file in this link:

Hi I’m experiencing the unexpected file format error.
This error is constant while I use my software.
Even the back up file has the same error.
Kindly requesting for a quick recovery on this file as I have to compete the project before the deadline.

I have uploaded the file to my google drive.
Please find the link down below.

Can you edit the link to allow access?

I have edited the link

Hi can anyone help? Unexpected file format on my project
Kindly requesting a quick response on this file.

Thanks and regards to the team!

I could only recover the components and materials. Nothing in the scene.


1 Like

It’s my totally unscientific and anecdotal impression that we are seeing an increase in “unexpected file format” errors recently. Perhaps since the introduction of the “universal” .skp type in 21? Probably I’m wrong, it may only appear that way to me because I’ve noticed it more. Does it feel more common to you @colin ?


This last file was a 2020 one, and the previous is 2019. A few others recently were 2015, and a couple of v8 files!

But, a few files in the last few months have been 2021 files. For a few of the issues we’ve been able to add code to help those cases.


Hi Colin were you able to look into this ?

Not sure why I hadn’t checked the file yet. I tried both the main file and the backup file, and couldn’t recover very much. Only the materials.

1 Like

Hi @Colin,
i got the same “unexpected file format” error when opening the file. Can you please try to recover it.
Here is the we transfer link: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

1 Like

Help, I have a corrupt file, the notification is “This does not to be appear as SketchUp model.” Please, this file is very important for me. @colin


@rpicht and @Izhmhndr : It helps when you ping the person you are trying to reach by adding the @ symbol followed by the name like: @colin
He will now be notified of this message just like you are…

1 Like


I could only recover materials and components. The scene will be empty, you will need to look at the components tray to see if there is anything useful recovered.

masterplanmodel_recovered.skp (15.2 MB)

This file seems not to be a SketchUp file. I can’t tell from the data in it what kind of file it is.

1 Like

rpicht., I was able to open your file with an older version of SU and resave it in the current version.

Try this one:
masterplanmodel (SU 2022).skp (13.7 MB)


What was the older version you used?

Never mind, 2017 is old enough. I will create a bug report about that.

Here’s a clue for you Colin, Repairing the model with an earlier version of SU enables the file to be opened by SketchupAPI.dll version 22.0.354.0

Here’s the record of the repair.

The original file was save as version 8.0.3117. So possibly before there was model checking on save. I don’t remember.