Error: The parameter is incorrect

Every time I click on 3d generated text in my file I get that error.
Snimka zaslona 2022-11-16 151302

I’m using Sketchup Pro 2022. I used pretty much only pull, move and copy tools. Plus making 3D text. Now suddenly I’m getting this error on all the 4 texts in different groups.
The file in question is here.
TEST.skp (1.1 MB)

I tried looking up the error but the only same error is while rendering which I don’t do.
How can I fix this?

Thanks for any advice.

I’m not seeing that message in SketchUp 2022 which would imply it’s coming from an extension you have but I don’t. What extensions do you have installed? Might be worth temporarily disabling them to see if the error goes away. Have you tried closing and restarting SketchUp? Did you install SketchUp Pro correctly? This requires right clicking on the downloaded installer and choosing Run as administrator.

BTW, your profile says you are using SketchUp Free (web). Since you are now using SketchUp Pro, please correct your forum profile. That information helps us help you.

I got the error message. No idea as to the cause, but it went away after I ran ThomThom’s Cleanup plugin. Might be from an extension, but I don’t use many…Nothing in Ruby console.

Like dave I don’t get the error.

I get an error if I selected e.g SP2 component inside a group.

I heve no idea (yet) why, the solution is:
Rename your Tag : named: TEKST

to e.g. Tekst (not all capital)

1 Like

I don’t know if they are related to the specific issue you describe (which I too can’t reproduce), but I notice two things about your model:

  • You have this little (approx. 4.4x7.5 cm) object placed far from the origin. That makes zoom extents go way far out, making everything tiny. If it is spurious, you can use the outliner to erase it.

  • The model has the SketchUp web watermark at upper right in the view, which says it was created using the web version, which matches your forum profile. But your post says you are using SketchUp Pro 2022, which is desktop. The difference is important because the web version does not support extension plugins. So if you are actually using web we can eliminate that cause.

I tried opening the file from the web version and got no error message.

Another piece of evidence: I did a string search of the SketchUp app, and (at least on Mac) there is no message that matches what you showed. That reinforces the notion that it is coming from an extension plugin. Do you have any 3DText editing extensions installed (e.g. ThomThom’s 3D Text editor)?

I don’t, and I get the message too. I don’t know what CleanUp fixes but it gets rid of it. I tried switching off some of the options (like geometry to layer 0 and edge materials) but couldn’t get the message to reappear. Deleting all tags got rid of the message, too.

1 Like

I also opened now in pure SU 2022 installation - without additional Extension -, and I was able to reproduce similar behavior’s I posted above.

I still have not been able to make it happen on my Mac. There may be some subtle difference between Mac and Windows? Or perhaps the locale setting affects it?

I can confirm that the tag TEKST is involved. Deleting it stops the message from appearing. But Cleanup leaves all tags as they are, and still fixes…

After you get rid of the message by renaming it to Tekst
You can rename back to TEKST.
So, I guess there should be some kind of invalid character in the original Tag name…

Seems likely, but probing via Ruby says the name is UTF-8 encoded and I don’t see any strange characters in it. Something is genuinely odd…

Yet one about Cleanup: If I run it without the “Purge unused” option, the error message remains. But running the native “Purge unused” does not fix the issue. Also, the issue remains if I run Cleanup without purge, and purge with native tools afterwards.
Go figure. Would need more sophisticated tools…@ThomThom, what does CleanUp do behind the scenes?

It’s odd that some of us see the message and others don’t. What’s the difference between our SketchUp installations?

@miposel I did notice some incorrect tag usage…
Screenshot - 11_16_2022 , 9_47_28 AM

…and a lot of unused stuff to purge from the file. Cleaning up the file reduced the file size by over 65%.
Screenshot - 11_16_2022 , 9_47_46 AM

I’ve been using the Pro version for a month now and this is the first time I’m getting the error so I don’t think it’s from installing it wrongly though I wasn’t the one to install it since this is a work PC.
Restarting Sketchup and the PC doesn’t help.
The only extensions I use are 3 that came with Sketchup; Dynamic components, Sandbox tools and Trimble connect. The file was created on Sketchup 2019 that does have some other extensions like Quatifier Pro installed. We use one file as a template for all project since it has all the blocks and layers set.

lol, this worked

Does sketchup hate caps?

Maybe. :wink:

But here some “interesting” thing happened with your file, because as I discovered (see my post above):
After you get rid of the message by renaming it to Tekst
You can rename back to TEKST.

I tested this out a bit more and while the rename of the tag does work, the error came up again and was fixed again with a rename.
Another thing as I work with the file is that when renaming the tag “tekst” it doesn’t update the name even though it fixes the error. It updates the name only after I click on it again.

1 Like