File opening with grey screen only, no functionality or image. Other files OK

Hello everyone! I am attaching a sketchup file which, all of a sudden doesn’t display anything once opened. All of my other sketchup files are OK when open. Looks like either the file is corrupt or my view is set incorrectly. I tried a few solutions already i found online but still no luck. https://drive.google.com/file/d/1yqLmZIMsmEhUFxUZBTjfuiboPNzSQpRo/view?usp=sharing

There were two text objects at an infinite distance from the origin:
“9,69 m²” and “4,42 m²”

Edit: I’ve edited this a few times, make sure you get the latest file.

1 Like

The problem is probably with text tags or dimensions with their reference removed. I don’t have the tools to fix it.

1 Like

Thanks Tig,
The code you posted worked well with the file the OP posted. It had several unlinked texts.
I also purged the file. The size shrinked to less than 30%.

1 Like

Wow thanks so much for your reply and for fixing he file. Any idea how I can prevent this from happening in the future??
T

Oh wow, yes probably because I imported something from the 3D warehouse and it loaded incorrectly! thanks for your help