Error on Component Options window when downloading in window


#1

Hello,

I am getting this error each and every time I have new sketchup window, I can download from within sketchup warehouse pop-up window, any of my models and the dynamic options window works fine. But if I have already downloded first model, it works - I do same exact thing and bring in second model from inside sketchup pop-up warehouse window, I get the following when I try and use the component option window.

ERRO: Callback function error: Unable to get property ‘length’ of undefined or null reference @ /dcbridge.js[601]

I can load the original file in separate window, then copy/paste it into other window window downloaded model and component options window works for that model.

I recently changed from 2015, to 2016 - but did experience similar error messages in 2015, Also when I download from warehouse other persons Dynamic Model - the options window works perfectly.

I removed all symbols like ",@,-,~ etc. from component name and detail still nothing. I have been comparing my component attributes with other warehouse dynamic models but cannot see the difference

Also interesting enough - All my models I “Lock” before uploading to warehouse, in a new window, I download the first model into sketchup, and it stays locked and options window works. Any second or third model I download into same window is now “Unlocked”, and the component options window shows same error.

I have 2015 version on work computer, I will try if I have similar issue on old version?

If I use the Components window to bring models into sketchup first via downloading direct from my warehouse, and also if I select folder on my computer to import same models from into sketchup - both ways causes the same error message.

The only way that works is to either download from webpage new model, copy and past into other window, or open local file and copy paste into other window so modles are grouped into one sketchup window.

I am getting the following code at the beginning of the ruby console:
1454770237892 JS WARNING: Unable to parse: {“entities”: [{“name”: “”, “typename”:

And I am getthing this code at the end of the console:
1454770237906 JS Callback function error: Unable to get property ‘length’ of undefined or null reference

I tried Matching the Component Name with the Title of model when you upload to warehouse, but doesn’t work. I am presuming this has something to to with the title or name of model?

I also just noticed that for any model I download from warehouse into open window from the pop-up window, and open the component attributes window, there is an Additional Top Group above my component attributes, this higher group always has same name as I place in the Title space when uploading model to warehouse.

OK - I installed 2015 version and downloaded model from warehouse and similar issue occurs, but says this now:
ERROR: Unterminated string constant @ [1]


ERROR: callback function error Dynamic Components
#2

This seems very similar to

otherwise can you load the model here

cheers
Philip


#3

To me returns me the same error every time I tried to edit a dynamic component of a project. I have been occurred component cut and paste it in a new window or instance of SU 2016 … and, eureka !, the problem disappeared.

Therefore, a way to deal with this error is to bring the dynamic component to another window of SU, edit it and re-paste it in place on the SU project window.

I hope will serve to solve the problem.

Cheers

Jesús Álvarez Lobo.

SPAIN.


#4

Yes etrnalsoul that is a quickfix but it is very unproductive. We want sketchup to fix this bug. it worked for me yesterday and today it wont work


#5

Please help resolve this issue. I updated to 2016 and am now having this issue.

  1. Open Sketchup
  2. Open an existing Dynamic Component saved in a SKP file on my hard drive
  3. File opens fine, no problems reported
  4. Click on Dynamic Component and then click on Component Attributes dialog box.
  5. Dialog window opens and opens a window with the following “Message from webpage” “No entity data returned” I click on the only option available “OK”
  6. Second dialog box opens with “Message from webpage” “Error: Callback function error: Unable to get property ‘length’ of undefined or null reference @ /dcbridge.js[601]” (same error shown on threedesign2014 comment on previous post.)

#6

what happens if you ‘import’ the same skp?

john


#7

If I import the same file, it adds a new object around my existing
component. The result is that I do not get the same error. The “Component
Options” menu no longer works on the component unless I then explode the
component to get it back to the same condition it was when I saved it last.
The Component Attribute box does work however I need to step through the
new object created etc. I also get the same error back again when I save
the component and then open it again. Does that help?


#8

Did that help? Is this scheduled to be fixed in an update?


#9

On my PC.
The [601]error has occurred if initial of a name of a folder that contains my SketchUp files is lowercase ‘u’.
It’s solved by replace the lowercase ‘u’ with a uppercase ‘U’ in the following manner.

C:\u**** >>> C:\U****


#10

I just had the same problem on my new laptop (1 month old). I just been install sketchup 2017(yesterday) (on top of 2016) maybe that’s what causing the problem. I don’t know because I barely work with my new laptop with skp2016. Maybe problem was there before!

Anyway, the problem was happening when I was clic on COMPONENT OPTION or COMPONENT ATTRIBUTS. I get the popup: error callback… [601]

My fix: I simply redownload skp, run the installer of 2016 again, then choose repair… then reboot: no error message anymore.

Maybe installing 2017 mess a bit with my 2016, and by running a repair on 2016, it put stuff back in place. I will be able to confirm that, I’m about to install 2017 on my desktop where I also have 2016 installed. A suivre… I’ll keep you informed.


#11

Still having the same issue with SU 2016 and now same issue with SU 2017! Please pay attention to this “Support” group.test.skp (68.3 KB)

If I

  1. Open this file in SU 2017
  2. Create a cube
    2.1 Draw rectangle from corner to corner
    2.2 push pull the rectangle surface up
    2.3 select the new cube
    2.4 Edit -> Make Component -> Create on the new component dialog box with all options defaulted
  3. Click on the Component Options dialog box with the new component selected
  4. Get these errors

I have had this issue on 3 separate computers now with 2016 and now with 2017


#12

@myhvac,

Thank you very much for your patience on this issue. Based on your observations I have confirmed that the DC error occurs when a folder name or a file name starts with lowercase “u”. I cannot thank you enough for finding this elusive bug !

Yogesh


ERROR: callback function error Dynamic Components
Ruby Errors in Dynamic Components
#13

@yogesh - can we have more of an explanation about this bug such as how to reproduce it?


#14

@jim_foltz, On a windows machine, create a folder name starting with lowercase “u” (e.g. “uber”), save the test.skp provided by @myhvac in this folder, follow the steps outlined in his post, the error should occur !


#15

I see - and confirm - the error when creating a dc in a folder starting with the letter “u”. What an odd thing. All I can think is the Windows folder separator character “” followed by “u” was getting confused for unicode?


ERROR: callback function error Dynamic Components
#16

Thanks, Great information. :+1:

I got exactly the same problem with Sketchup Pro 2017 on Windows 10, x64.
I have spent several hours trying to understand why Dynamic Component didn’t work.

Moving the file to another folder that don’t start with “c:\u…” did the trick. :grinning:

Thanks.


#17

Hi,
I have similar issue with dynamic components. I am running Windows 10 x64 and Sketchup Pro.
When I create dynamic component, everything works. But, when I save the file and try modify dynamic component I get error message “No entity data returned” and then "ERROR: Call back function error … "
I found that it has something to do with file location. When saved in Document folder, it works fine.
Any reason why? Thanks.


#18

Hi,
Check the path name where the file was stored. Top level cannot start with the letter “u”.

My path was C:\usr\emerson\dropbox.
Moving to another path works (c:\temp\usr\emerson\dropbox).

BR / e


#19

Hi, thanks for your reply, but my path looks: e:\xVx\RC\Fiesta WRC 2017\fiesta WRC 2017 - 001.skp
As you can see there is no “u” letter. The problem must be somewhere else.


Is there an alternative to the Component Attribute Interface?
#20

OK.
What happens if you copy the file to another folder (for example e:\temp).
Does it work there?