Callback Function Error from query of dynamic components

Please help resolve error(s) that prevent Sketchup Make 2017 from editing dynamic components. After selecting the dynamic component and right clicking it, then selecting “Dynamic Components” and then “Component Options”, the errors I receive are:

Message from Webpage
ERROR: Callback function error: Object doesn’t support property or method ‘attachEvent’ @ /dcbridge.js(601) and:

ERROR: Callback function error: Object doesn’t support property or method ‘attachment’ @ /dcbridge.js(601)

Also, the Component Options window is blank.
Blank Component Options

I have tried the following to resolve the issue without success.

Updated the Dynamic Components Extension to the current file in the Extension Warehouse.


Searched for file names that begin with a lower case “u” and did not find any.

Tested the behavior with many different dynamic components from various sources and all failed.

Tested the behavior in an old version of Sketchup 2014 and found the same error(s).

Repaired the 2017 installation file.

During many years of using Sketchup I have never seen this until a few days ago.

I wondered if uninstalling and reinstalling 2017 would solve the issue but hesitated when I couldn’t find specific instructions to do that.

My work is suffering as a result of this and I would really like some help.

Thanks in advance

How about folder names? Windows documents folder? Just saw someone’s screenshot with “users”
/u is not the only forbidden sequence.

You are not allowed to use SketchUp Make for your work. You need to be using Pro.

1 Like

I checked folders and other potential problem strings and didn’t find any.

My work is strictly non-commercial.

Can anyone help me figure this out?

Open the Ruby Console before you open any of the DC dialogs and see if there are any errors displayed.

Apparently, I have come across a similar problem.

I was messing around and decided to make a component (dynamic) that I could scale in just one axes. This is something I often do with framing lumber, steel shapes, etc.
I had made a component of a shallow electric box and as the model that contained the component isn’t anything critical, I figured I’d mess around with making that a DC out of it (Step 1 in attached image). But when I clicked on the “Create and customize …” green boxes and triangle icon (Step 2), I get this weird error popup (Step 3) and when I click the to close that error popup, I get another weird error popup (Step 4) in 2nd attached image.

Although the images attached show the effect in Verson 2021, the original model containing the component was made in version 2022 where I experienced the weird error popups initially. I opened the model in version 2021 to see if the problem was unique to 2022, but apparently not.

I opened a new empty model, created a cube, made that cube into a component and tried to make that a DC. Success. No problems at all. Back in the model with the shallow box component, creating a cube and making it into a component brings forth the errors. I saved the shallow box component to disk, opened it in a new, empty drawing, and the DC command works.

What’s wrong with my model, and how did I get to the point where in that file, I can’t make a DC?

undershelf outlets.skp (75.7 KB)

do not use “u” for start of file. rename it “an undershelf outlet” or something


Really? That an idiosyncrasy of a file name causes the errors is difficult for me to process. Your solution works, but why? Please explain.

I don’t no why, but if only a small amount of effort was diverted from live components to dynamic, I sure these crazy workarounds would not be needed

1 Like

I understand that most of these stem from that Dynamic Components is not in the native SketchUp code but is a Ruby extension.

1 Like

yes, I believe that’s true, but if other extensions can have cleaner code why not a Trimble authorised one?


Dunno. Been complaining about these since DC-s were introduced, was it in version 4, not quite sure.

1 Like