Dynamic Component Options Error


#1

Dynamic Options giving me an error. This is a template file I have used a million times without issue, dynamic options has always worked. I just installed Windows 10 Home (previous windows died), then downloaded SketchUp Pro 2016, opened the file and dynamic components isn’t working. Keeps telling me “no entity data returned”, then “Callback function error: unable to get property ‘length’ of undefined or null reference @ /dcbridge.js[601]”.

Any ideas what might be causing this error?


#2

reinstall dynamic components from extension warehouse so as to update to current ruby requirements


#3

reinstalled dynamic components from extension warehouse, but it didn’t work. Any other ideas?


#4

Did you restart SU after reinstalling the extension?


#5

Yes, I restarted SU after reinstalling the extension. Also just tried reinstalling SU completely, then reinstalling the extension again; no luck.

I’ve got windows 10 home on my laptop, SUPro 2016 and it works well.


#6

check Internet explorer is up to date…

DC’s use it…

john


#7

I have IE11, most recent version.

I downloaded 2015 trial version and it works fine.


#8

Not sure if this will help.

I was having a problem with the DC Options and tried updating & reinstalling with no luck.

Disabling the Dynamic Component Extension using the Extension Manager and then restarting Sketchup and enabling from the Extension Manager (I repeated this a couple of times and maybe even restarted the computer before it started working properly again).


#9

That’s some black magic right there. I’ve seen this error also and there doesn’t seem to be any rhyme or reason to it’s appearance. For me it doesn’t typically last too long if you just continue trying to work with the component.