Getting error message "No Entity Data Returned" on dynamic component

I have been trying to use the dynamic component options for the Kraftmaid Cabinetry from the 3D Warehouse. There are many different cabinets under this umbrella. I’ve downloaded several now, and for each one get the error pop-up box when I try to go to the dynamic component options.

This is happening with my current Pro version. Just as a matter of trouble-shooting, I tried the same thing on an old version of SU Make 2017 and got the same result. Can someone explain?

Diane Dieterich

What is your current Pro version? Perhaps you could complete your profile?

Check to make sure that the Dynamic Components extension is up to date. Save the file and try restarting SketchUp. Does that change anything?

This error happens on Windows, if your SketchUp file name starts with a ‘u’. A model named ‘upstairs.skp’ will show the error, “Upstairs.skp” won’t show the error.

What is the name of your file?

1 Like

Hmmm…interesting. I just checked again, and the problem seems to have resolved itself and the components are again behaving normally. Mysterious…I’ve used these Kraftmaid cabinet components hundreds of times as a kitchen designer, and never had that happen before. HOpe it was a one-time deal.

Hi, this is an older thread, but I have the same problem. I had a 2017 version that had the same problem and I thought it was an old version.
I bought the 2022 version yesterday and the problem still persists. I create an object, set the behavior and everything works. I save, open and it is no longer possible to edit the properties. The error message “No entity data returned” is displayed followed by "ERROR: Callback function error: Cannot read length undefined … /dcbridge.js[601].
The strange thing is that if I copy the object, create a new file and paste it, it can be edited again. However, when I save it and open it again, the dynamic component cannot be edited again. What is it please?
AAA.skp (173.9 KB)

The file you posted worked for me OK.
There has been no update to the Dynamic Component extension for years. So still, if your file name or a folder name in your path starts with a lowercase “u”, the DC extension fails.

1 Like

I have the same problem

the Dynamic Components extension gives the error when the file is in a network folder or in a synchronized local folder - it disappears if I move the same file to a local folder