Error message when trying to Uploading new 3D files to 3d Warehouse

Having an issue with 3D warehouse. There is a error message when trying to Uploading new 3D files to 3d Warehouse. I am using sketchup 2018

What is the error message exactly?

Your profile indicates you are using SU2018 Make which doesn’t exist. Are you using SketchUp Pro?

Yes my mistake I am using pro. when I try to upload 3D file from with in the sketch file, It says…Client was not able to upload model file. Try again later. So I try to upload it on the safari internet and it just stays in process mode no movement. The files are under 50 MG so I do not no if 3D warehouse is down at the moment or if there is a bug issue. I tried several times with in sketchUp and on the internet 3D warehouse website and no success made

Sorry I meant to say the files are under 50 MB

I just uploaded a file to the Warehouse as a test. No problem here.

What Mac OS version?

What happens if you use Chrome to upload the file to the Warehouse?

It is version 10.13.6 High Sierra. I have only used safari and haven’t have any problem until now. Ok l tried chrome and it works thank you. I am wondering maybe I need to change the settings for safari

@Kjames82 Thanks for bringing up the issue. We’re experiencing some problems with uploading on Safari 13.0.1 and currently working on a fix for this.